RSS
Sort by » date activity ▼ answers views votes

164 questions

Tagged
  • x
57
views
2
votes
1
answer
Last activity 2017-04-27 09:21:44 +0200 by Petter Myhre flag of Norway

nrf52832 does not work well at power on

I download my program to PCA10040 DK board and the program will make the led1 blink two times. First I download program to flash and all work well.The led1 will blink two times and stop. But when the board ... (more)

30
views
no
votes
1
answer
Last activity 2017-04-26 14:33:04 +0200 by akshaey

nrf52 P19 external programming

I really need your help regarding a problem. I developed my own pcb with nrf52 and verified it with your hw engineer. I just finished soldering and hooked it up with your Development kit via P19 to program it via ... (more)

41
views
1
vote
2
answers
Last activity 2017-04-21 18:01:48 +0200 by endnode

nrf_log from debug port

Hi, I'm using nrf51dk board and nrf_log came out correctly on my RTT terminal with built in module. After that I use debug port (P20) to program to my custom module. I've vdd, gnd, swdio and swdclk connected ... (more)

32
views
no
votes
no
answers
Last activity 2017-04-06 16:10:40 +0200 by jcormier

nRF52 SDK12.2 fails SOFTDEVICE_HANDLER_INIT when debugging

Trying to get the debugger working with Eclipse on SDK 12.2 using the nrf52832. Using the ble_app_hrs example, I can flash the application and the "Nordic HRM" device shows up on my phone. However if I try to debug ... (more)

24
views
3
votes
1
answer
Last activity 2017-04-04 08:38:21 +0200 by schef

JLinkRTTClient wont show all debug prints?

I am using NRF52DK and trying to debug an SPI transfer, using SEGGER_RTT.h to print. However, printing of the logs are not consistent. Some debug lines do no appear in the JLinkRTTClient.

I have put SEGGER_RTT_printf(0,"SPI Tranfer ... (more)

113
views
no
votes
1
answer
Last activity 2017-03-24 11:07:02 +0200 by Sigurd flag of Norway

what kinds of flag Do I set, when I use sdk13 in keil-c debug mode

Hi I use nRF52832 and move my project to SDK13. I want to use debug mode in keil-c and try to find after ble_db_discovery_start function call why no csc_c_evt_handler_t call but I dont know why the MCU just reset himself ... (more)

61
views
no
votes
1
answer
Last activity 2017-03-21 13:16:55 +0200 by AmiguelS

nrfjprog ---pinreset not working on nRF52

Hello! I am using a custom board that contains a nRF52832 device. The board has the SWDIO and SWDCK lines connected, which I have successfully been using to flash and debug the firmware.

However, I cannot seem to make the ... (more)

51
views
no
votes
1
answer
Last activity 2017-03-13 10:47:35 +0200 by Bjørn Spockeli flag of Norway

Ozone debugger and sources [closed]

Hello,

I test new SDK 13 and i have a problem. I don't success to debug bootloader. When i open .out file into debugger, sources are not complete (main is missing) so i can just know actual code address ... (more)

96
views
1
vote
no
answers
Last activity 2017-03-07 03:13:06 +0200 by tyler

Debugging a APP_ERROR_CHECK

I am working on a project using a BLE Nano and Nordic sdk 8.1. I included the ble_flash.c, ble_error_log.c, and ble_debug_assert_handler.c files in my include path and c source files. I also added -DDEBUG to the ... (more)

128
views
no
votes
no
answers
Last activity 2017-03-06 12:56:42 +0200 by Tarik

How to solve eclipse debug issue

Hi, Since the moment I installed and configured eclipse following this tutorial: https://devzone.nordicsemi.com/tutori...

I was never able to successfully debug any of the programs.

one possible cause is that I never got eclipse to import the ... (more)

60
views
1
vote
no
answers
Last activity 2017-03-02 12:29:57 +0200 by liudijiang flag of China

what’s difference between debug mode and release mode?

hi,

my device is nrf52832

i run my spi sd card driver fine in debug mode, but when i download it ( F8 ), it can not work!

so my question is what is the difference between debug mode and release mode ... (more)

63
views
no
votes
2
answers
Last activity 2017-03-01 14:49:31 +0200 by Tarik

Flash and debug using eclipse and GNU

Hi,

I used the code ble_app_uart_c on board 10028 as a base for my custom board.

My board is nrf51822 QFAA based so I changed all occurances of nrf51422 to nrf51822 and xxac to xxaa on the makefile. I also ... (more)

879
views
8
votes
2
answers
Last activity 2017-02-28 10:38:36 +0200 by Martin Børs-Lind flag of Norway

Debugging NRF51422?? How can i use err_code to debug my nrf51422??

I'm a beginner, the question might be simple but its really important for me. where does this error codes get store?? How to make use of err_code and whats the best way to debug my application?

349
views
3
votes
1
answer
Last activity 2017-02-21 15:52:57 +0200 by Sigurd flag of Norway

Debugging with breakpoints: correct gcc flags [closed]

I'm building a software for the nrf5822 using pc10028. I'm using CMake and after following both http://morf.lv/modules.php?name=tutor... and https://devzone.nordicsemi.com/blogs/... I successfully made the debugger to work... except I ... (more)

43
views
1
vote
1
answer
Last activity 2017-02-20 11:42:07 +0200 by Stian flag of Norway

Eclipse CDT debug and NVIC registers

I'm using Eclipse CDT for debugging according to the tutorial on this site. I've installed the device pack and I do see the nRF52 peripherals in the debug view. However all the general ARM Cortex-M4 peripherals are missing ... (more)

116
views
no
votes
1
answer
Last activity 2017-02-14 14:53:57 +0200 by Kristin flag of Norway

nrf51 wont run without debugger

Have an nrf51 board design that doesn't want to run without a debugger. When programmed, the debugger can run the board. When the debugger is removed, the board does not seem to run at all.

The SWDCLK line has ... (more)

189
views
no
votes
1
answer
Last activity 2017-01-16 13:46:18 +0200 by Ole Bauck flag of Norway

nRF52DK Debug In

Hi,

Where can I find more information on how to use the nRF52DK Debug In port?

Regards, Mikael

77
views
1
vote
1
answer
Last activity 2017-01-12 09:05:20 +0200 by Jørgen Holmefjord flag of Norway

Where to specify the output file for the build on Embedded Studio

Where is the output Hex file for building the project on Segger Embedded Studio?

126
views
1
vote
1
answer
Last activity 2017-01-12 09:02:18 +0200 by Bjørn Spockeli flag of Norway

MQTT stops responding after fixed number of subscribe and publish

Hi everyone,

I was having RAM overflowed with stack issues which were resolved using suggestions here. Now I am facing another issue. While running mqtt I can only do a fixed number (15) of mqtt publish or subscribe requests and ... (more)

92
views
1
vote
1
answer
Last activity 2016-12-19 15:09:18 +0200 by Paul Michell

How do you setup Ozone to work with the nRF51DK?

Hello,

I have installed Ozone (V2.22g) on Kubuntu (16.10 64bit) and attached a nRF51DK via USB. I can successfully run a test program using nrfjprog with the following script:

# Commands to flash nRF51-DK using RF5x-Command-Line-Tools-Linux64
PATH=$PATH:/opt ...
(more)

59
views
no
votes
1
answer
Last activity 2016-12-16 11:21:40 +0200 by Sigurd flag of Norway

Custom NRF51822 board issue while detecting

I have a Custom Board made by using nrf51822 soc but pc is unable to detect the board by using Jlink debugger. Stlink was able to detect only when frequency selected as 20khz and by using openocd, it is not ... (more)

108
views
1
vote
2
answers
Last activity 2016-12-16 10:44:27 +0200 by Jawad

SPI failure in case of modifications to unrelared code segment

Hi everyone,

I am using nrf52832 with SDK version 11.0 for an IoT application. I am communicating with Atmel ATWINC 1500 module through SPI in order to connect to Wifi. My code was working fine until I added few ... (more)

3k
views
6
votes
3
answers
Last activity 2016-12-01 11:46:11 +0200 by Shriram

Programming nRF52 with OpenOCD

Hi, I have a BMD-300 (nRF52) module that I'm attempting to program with OpenOCD and an ST-link from Linux (it worked great for nRF51 so I was trying to keep the same tools).

$OPENOCD/src/openocd -s $OPENOCD/tcl ...
(more)

443
views
3
votes
1
answer
Last activity 2016-11-30 12:23:13 +0200 by Sigurd flag of Norway

UART debug logger

Hello,

I am using SDK v12.1.0 and I want to get the debug logs over UART

I followed the Logging Sink Configuration to enable UART logging and compiled the Health Thermometer Service example, which has statement like NRF_LOG_INFO ... (more)

115
views
1
vote
1
answer
Last activity 2016-11-22 12:51:54 +0200 by Bjørn Spockeli flag of Norway

Can I debug BMD300 through SWD interface

Hi developers,

I am trying to collect data from an AFE (ADS1298) and could get some values. Inorder to check the accuracy I need to plot this value. I am programming this external board using PCA10040 nRF 52DK. I did ... (more)

68
views
1
vote
1
answer
Last activity 2016-11-18 06:08:43 +0200 by Vishnu Pradeep flag of India

RTT logging not happening with softdevice code

Hi,

NRF_LOG_PRINTF() is working fine with peripheral examples in SDK11. but when I try to do the same in ble_peripheral examples it is not working. I have defined the following BLE_STACK_SUPPORT_REQD NRF_LOG_USES_RTT=1 BOARD_PCA10040 NRF52_PAN_12 NRF52_PAN_15 NRF52_PAN_20 NRF52_PAN_30 NRF52_PAN_31 NRF52_PAN_36 ... (more)

96
views
1
vote
1
answer
Last activity 2016-10-29 08:08:41 +0200 by Vidar Berg

bootloader_util.c fails to build without optimization

I'm trying to add debug information to ble_app_hrs using nRF5 SDK 10, softdevice s110 version 8.0.0, building for an nRF51-DK target (PCA10028) using ARMGCC. I've found that by changing the optimization level in the Makefile at ... (more)

41
views
no
votes
1
answer
Last activity 2016-10-25 13:59:15 +0200 by Ole Bauck flag of Norway

Pause peripherals when hitting a breakpoint?

Is there a way to pause all peripherals when hitting a breakpoint? In particular, I would like to freeze the RTCs when I hit a breakpoint. My app wakes up once a second, and I pause the code for too ... (more)

709
views
5
votes
4
answers
Last activity 2016-10-22 04:12:42 +0200 by Shay Ohayon

Is it safe to use USB dp/dm pins for SWD interface?

We are building a new version of a small device with the new nRF52832. Its only external connection is a micro USB plug that we use for charging - we do not need it as USB data interface. But would like ... (more)

33
views
no
votes
1
answer
Last activity 2016-10-18 03:11:30 +0200 by Pascal

[title:arduino] No ACKs after initial send

Hi All,

BLE Nordic Stack: 0.9.7 Tiny Circuits: Ardunio + Nordic nRF8001 Board

 First time post, and hoping someone has run into the same issue that I am.   I am in the process of writing a custom sensing ble ...
(more)

Statistics

  • Total users: 18499
  • Latest user: Andre Goodman
  • Resolved questions: 9208
  • Unanswered questions: 2543
  • Total questions: 21737