RSS
Sort by » date activity ▼ answers views votes

9 questions

Tagged
  • x
44
views
no
votes
no
answers
Last activity 2017-10-19 14:11:30 +0200 by Davide flag of Italy

Power Profiler Kit tremendous delay, what's going on?

Hello, I'm trying to measure the current profile with the PPK (HW Rev:1.1.0, SW: 1.1.0) but I see a lot of strange behaviors.

My firmware initializes everything and the waits a button event. When ... (more)

45
views
3
votes
1
answer
Last activity 2017-10-17 09:04:50 +0200 by Martin Børs-Lind flag of Norway

Power consumption reading a large fifo - Easydma list vs Cpu reading

I am reading a large FIFO buffer from a sensor and there are at least two ways to do it - by simply reading the FIFO using the CPU and SPI in chunks of 255 byte blocks, or using EasyDma list ... (more)

20
views
no
votes
no
answers
Last activity 2017-10-13 04:05:55 +0200 by ShannonPahl

PPK + DK, peripheral current not showing up in PPK [closed]

I've connected some sensors using I2C and SPI to a DK and their power consumption is not being reflected in the PPK. Without any BLE acitivity, the current is almost zero whereas I'd expect atleast a constant 150uA ... (more)

183
views
1
vote
1
answer
Last activity 2017-08-10 14:07:59 +0200 by wilhelmsen

PPK Software

I was just wondering if theres plans to migrate the PPK software to be an app in the NRFConnect tool. I love the NRFConnect tool and I wasnt able to get the PPK software running on a mac. I ended ... (more)

179
views
2
votes
1
answer
Last activity 2017-08-01 09:25:56 +0200 by wilhelmsen

PPK software - latest version

I am using a PPK with v1.0.0, but elsewhere in DevZone I see references to later versions of the software. Where can I download the later versions from? Have I missed a link?

Thanks

1k
views
no
votes
1
answer
Last activity 2017-07-31 13:16:55 +0200 by Bjørn Spockeli flag of Norway

PPK Question [closed]

Hello,

We encounter the problem after upgraded the PPK software. There are different results when using PPK v1.0.0 and v1.1.0.

  1. Using PPK v1.0.0 image description

  2. Using PPK v1.1.0 image description

(The highlighted spikes are active by ... (more)

120
views
no
votes
1
answer
Last activity 2017-06-01 10:54:06 +0200 by Sigurd flag of Norway

PPK Current Measurement

Hi,

Just wanted to confirm what the average current measured by the PPK represents. So for example if I have AVG in average window as 2.5mA, is that only the BLE (i.e. transmission) current or all of the ... (more)

156
views
3
votes
2
answers
Last activity 2017-01-05 17:12:59 +0200 by ThierryC

PPK little negative offset which is breaking AVG value

I use PPK wit ha stardard setup with all switches set to DK. Everything works fine, excepted that I have a little offset and the IDLE state is negative... which make the AVG value to be wrong (negative). See following ... (more)

424
views
3
votes
2
answers
Last activity 2016-12-12 21:34:06 +0200 by Werner Johansson flag of Sweden

Power Profiling Kit printing "Range not Detected" after running for a few minutes

After a few minutes of running, the Power Profiling kit will start printing out "Range not detected" messages in the console. It appears to be related with the "Average" window length. Increasing the average window length (I had it set ... (more)

Statistics

  • Total users: 24931
  • Latest user: Mia O'Connor
  • Resolved questions: 10681
  • Unanswered questions: 3448
  • Total questions: 26145

User menu

    or sign up