RSS
Sort by » date activity ▼ answers views votes

73 questions

Tagged
  • x
58
views
1
vote
1
answer
Last activity 2017-09-11 22:17:53 +0200 by RK flag of Singapore

rtt when link disconnected

I have an example combining BLE, UART and SPI in which I use RTT to watch the startup process. The SoC is nRF52 (BLE Nano2); building with armgcc. This works ok when JLink is connected. However, if I unplug the ... (more)

45
views
2
votes
1
answer
Last activity 2017-09-11 14:14:33 +0200 by Jørn flag of Norway

Multiple devices debug in RTT viewer

Hey, is there a possibility to connect two or more devices to RTT viewer?

62
views
no
votes
no
answers
Last activity 2017-09-11 11:14:13 +0200 by Ahsan

RTT viewer multiple windows

Hi,

It looks like system (laptop windows 7) is not supporting more than two windows of RTT viewer simultaneously. When I connect, third one, it disconnects, one of the two's.

Is there any way to connect four windows of ... (more)

34
views
no
votes
2
answers
Last activity 2017-09-08 17:35:36 +0200 by Turbo J

RTT message logging with power cycles

Greetings,

I've got an embedded project where a NRF52 is a "co-processor". The NRF52 used to output UART debug messages but I've since changed this to use RTT.

During operation, the main microcontroller frequently performs a power cycle ... (more)

54
views
no
votes
3
answers
Last activity 2017-09-08 13:57:07 +0200 by Starry

SDK14 52810 rtt log

I used the 52810 board, with the SDK14. I modified the 52810 according to the official website related to the relevant definition. I can run the code but it does not print. The same code is programmed on the 52832 ... (more)

35
views
no
votes
no
answers
Last activity 2017-09-07 16:45:33 +0200 by Nathan Morsa

Radio not working when RTT is in use

We are using a nRF52840 (QIAAAA) on a custom board which replicates exactly the schematic used by the development kit (PCA10056). When using Segger RTT for debugging purposes, the board does not emit any BLE packets (no errors are reported ... (more)

25
views
no
votes
1
answer
Last activity 2017-09-07 13:18:29 +0200 by Terje Schjelderup flag of Norway

ble_app_buttonless_dfu use RTT log

Hi, I'm useing ble_app_buttonless_dfu to get log with UART is possibly. I want to change RTT log. How can I do? Board is nRF52-DK. SDK is nRF5_SDK_14.0.0_3bcc1f7.

95
views
no
votes
1
answer
Last activity 2017-09-05 12:22:33 +0200 by Petter Myhre flag of Norway

SEGGER RTT printf() problem

Hi, I have problem with using printf() in SEGGER RTT.

I've read tutorial and others about SEGGER RTT printf() problem, but they didn't work.

When I use printf() in RTT and compile I got error like this:

[._build ... (more)

102
views
1
vote
1
answer
Last activity 2017-08-25 05:12:02 +0200 by piepie

NRF_LOG_DEBUG() doesn't output in SDK14

Hi, I am running the ble_app_uart example from nRF5_SDK_14.0.0_3bcc1f7, and found that NRF_LOG_DEBUG() doesn't cause any log output. Although I have set #define NRF_LOG_ENABLED 1 and #define NRF_LOG_DEFAULT_LEVEL 4. image description

However, it's OK in the ... (more)

44
views
no
votes
1
answer
Last activity 2017-08-23 15:34:10 +0200 by Kamil Sroka

RTT logging with freeRTOS and nRF5 SDK for Thread

I am trying to test a combination of BLE central role, Thread with CoAP server and FreeRTOS on an nRF52840 using version 0.10.0 of nRF5-SDK-for-Thread.

I don't seem able to get RTT traces from any example based ... (more)

22
views
no
votes
no
answers
Last activity 2017-08-22 18:21:25 +0200 by Ignacio Lopez-Negrete flag of Spain

RTT infinite loop over initial commands

Hi,

I have just updated the SEGGER Jlink tools to the latest version v6.18b.

Under Keil debbuging the J-Link RTT Viewer (or client) shows the initialization commands in an infinite loop (one after the other starting from the first ... (more)

63
views
2
votes
2
answers
Last activity 2017-08-21 15:13:24 +0200 by Turbo J

gpiote interrupt cannot wake sd_app_evt_wait? [closed]

I have tried to use sd_app_evt_wait() to sleep cpu, and use gpiote interrupt to wake up cpu from sleep. However, gpiote interrupt cannot wake up cpu. When I use __WFE(), gpiote interrupt can wake up cpu. And even if I ... (more)

96
views
no
votes
1
answer
Last activity 2017-08-09 14:23:33 +0200 by ndarkness

Undefined reference to SEGGER_RTT_printf, why?

HEllo I am having an error saying

Undefined reference to SEGGER_RTT_printf

I have looked into this post and tried it, however I am not able to fix it,I have defined GLOBAL_DEBUG on my preprocessor settings but the linker seems ... (more)

107
views
no
votes
2
answers
Last activity 2017-07-27 12:20:08 +0200 by ble999

RTT & RTT disable sdk 12/13 nRF52832/nRF52840

Dear all,

Help please, I'm evaluating ble_app_uart (Central/Peripheral) but I don't understand how to disable the echo I have on the RTT USB VCP

When I send data from the UART, I got (PCA10056/10040) the data ... (more)

95
views
no
votes
1
answer
Last activity 2017-07-21 16:28:04 +0200 by saiteja

How to print out the time stamp in nRF log [closed]

Currently developing on NRF52 sdk12

I want to be able to show time stamp minutes:seconds:miliseconds on my RTT viewer, when I print my data out from the uC. Any hits on how to do that?

I'm looking ... (more)

126
views
no
votes
1
answer
Last activity 2017-07-21 13:29:41 +0200 by Hung Bui

How to add timestamp in RTT viewer using NRF log module

Currently developing on NRF52 sdk12 with a terminal

In my source code i have nrf_log_init(null), and this allows me to print stuff to the RTT viewer.

Now I want to be able to show time stamp minutes:seconds:miliseconds ... (more)

82
views
2
votes
1
answer
Last activity 2017-07-08 14:25:37 +0200 by Turbo J

Jlink RTT Viewer not detecting Target Device Automatically

Hi,

I installed the latest version of Jlink 6.16f. I connected my nrf52-dk and on opening the RTT viewer, I always need to specify the target device manually instead of it being detected automatically. I am also attaching a ... (more)

35
views
no
votes
no
answers
Last activity 2017-06-30 17:30:36 +0200 by Steve H

RTT Viewer colours

Hi all,

I am finding that the RTT Viewer is very unreliable at changing colour when sent commands from two different nRF52-DK boards. The text is coming out correctly, but the colours only change intermittently. I've tried dropping the ... (more)

40
views
no
votes
no
answers
Last activity 2017-06-29 09:35:13 +0200 by Jørgen Holmefjord flag of Norway

Error: L6200E: Symbol SEGGER_RTT_WaitKey multiply defined (by segger_rtt_1.o and segger_rtt.o).

Hi,

I followed the RTT tutorial but When I try to BUILD the project I got this error. What is it?

Error: L6200E: Symbol SEGGER_RTT_WaitKey multiply defined (by segger_rtt_1.o and segger_rtt.o).
Error: L6200E: Symbol SEGGER_RTT_WriteString multiply defined (by ...
(more)

62
views
no
votes
no
answers
Last activity 2017-06-19 12:07:41 +0200 by satheesh

could not connect with RTT

hi team,

i have tried to connect my device with RTT. i could not connect. i just followed the instruction as below link

https://devzone.nordicsemi.com/tutori...

if i insert the function( SEGGER_RTT_WriteString(0, "Hello World!\n"); ) in main ... (more)

100
views
no
votes
2
answers
Last activity 2017-06-16 14:30:49 +0200 by Sigurd flag of Norway

How to use RTT in bootloader project

Hi,I want to use RTT in bootloader project. First,i add all files(SEGGER_RTT.c ,SEGGER_RTT_printf.c,RTT_Syscalls_KEIL.c) to my bootloader project(Picture 1). Second,I add nrf_log.c to my bootloader project and define NRF_LOG_USES_RTT(Picture 2 ... (more)

34
views
no
votes
no
answers
Last activity 2017-05-10 07:44:23 +0200 by Nash.Hsu

free RTOS with RTT view

Example project: blinky_FreeRTOS_pca10028.uvprojx I include SEGGER_RTT.h file. After execute vTaskStartScheduler() function.

SEGGER_RTT_printf(0, "Hello World from SEGGER! %d\r\n", i); <== It not working.

But before execute vTaskStartScheduler() function. SEGGER_RTT_printf(0, "Hello World from SEGGER! %d\r\n ... (more)

114
views
no
votes
1
answer
Last activity 2017-03-28 07:21:37 +0200 by zkshen

NRF_LOG_INF didn't show in RTT

I use SDK12.2, and I have enabled NRF_LOG_BACKEND_SERIAL_USES_RTT and NRF_LOG_ENABLED. But there was nothing show in J-link RTT and don't know why.

206
views
no
votes
3
answers
Last activity 2017-03-27 14:43:17 +0200 by Jacob

RTT logging from application started by bootloader

Hello, Is it possible to get logs (RTT) from an application started by a bootloader? As of now I don't get anything after the bootloader has jumped to the application start address.

If I run the application separately it ... (more)

377
views
1
vote
1
answer
Last activity 2017-02-28 13:26:33 +0200 by schef

SEGGER_RTT works but NRF_LOG not

Hi, can you help me out please: I have followed https://devzone.nordicsemi.com/questi... and have configured as it shows.

But NRF_LOG_INFO does not work however SEGGER_RTT_printf does. What should i do? Thanks

367
views
2
votes
2
answers
Last activity 2017-02-24 12:01:35 +0200 by AmiguelS

Connect to multiple Segger J-Link debuggers

Hello!

I need to interact with two J-Link debuggers, connected to the same PC at the same time. I would then read and write data to the devices connected to the debuggers.

To send/receive the data, I was thinking ... (more)

138
views
1
vote
1
answer
Last activity 2017-02-21 10:36:48 +0200 by Sigurd flag of Norway

What are the right memory mapping for nrf52 & SEGGER Embedded Studiov3?

HEllo,

I am trying to compile for the nrf52 one of the examples that are included in its SDK12.2, to be precies, I am using experimental_ble_app_blinky_pca10040_s132, I have been able to compile it with KEIL but now I would ... (more)

260
views
5
votes
1
answer
Last activity 2017-02-13 15:32:17 +0200 by SEGGER - Johannes

SEGGER RTT printf not printing all the lines.

I want to read whole flash memory using for loop and see how long it takes. What i have noticed is that it does not print all the lines. On the other side i ask myself: Does it read all ... (more)

525
views
no
votes
no
answers
Last activity 2017-01-29 08:40:54 +0200 by Jan L

How to print float values using SEGGER RTT

Hi, My question is similar to this https://devzone.nordicsemi.com/questi... but I can't get it to work.

I am using SEGGER_RTT_WriteString and sprintf for debugging, but I am not able to print a float value such as ... (more)

297
views
1
vote
1
answer
Last activity 2017-01-19 15:22:47 +0200 by Jørgen Holmefjord flag of Norway

"SEGGER_RTT_CONFIG" problem

Hey! I was trying to modify s132 ble_beacon example to s140 for my nRF52840 DK but I couldn't build it in Segger Embeded Studio. What is the problem with "SEGGER_RTT_CONFIG"?

image description

Statistics

  • Total users: 24465
  • Latest user: Odette Pemulwuy
  • Resolved questions: 10456
  • Unanswered questions: 3314
  • Total questions: 25472

User menu

    or sign up

Recent questions