RSS
Sort by » date activity ▼ answers views votes

946 questions

Tagged
  • x
1
view
no
votes
no
answers
Last activity 2017-08-18 01:08:35 +0200 by ajc

buttonless DFU SDK v14.0 problems

Hello,

I am having difficulty downloading an application using the sample images provided. It looks like the application boots into the bootloader, there is a brief message that it is downloading but then the name changes to DFUTEST and LEDs ... (more)

7
views
no
votes
no
answers
Last activity 2017-08-17 17:17:23 +0200 by Alex

TWI blocks after send receive sequences

Hello

I am using a custom board, based on nRF52832 CIAAB0. I have also S132 installed, and I am using SDK 13.1.0. TWI pins are P0.16 - SCL & P0.18 - SDA. The code is based on twi_sensor example ... (more)

13
views
no
votes
no
answers
Last activity 2017-08-17 16:33:09 +0200 by ndarkness

Can I use same handler for two different SPI's interfaces?

HEllo,

I was wondering whether or not is advisable to use the same handler to handle transmission/reception of data over SPI0 and SPI1 interfaces.

I have two sensors connected each one to each SPI, let's say sensorA to ... (more)

33
views
no
votes
1
answer
Last activity 2017-08-17 15:15:05 +0200 by Håkon Alseth

Why was a malloc with heap_size = 0 successful?

We started with the default project that have no heap. Added mallocs to the system and they seemed to succeed, without realizing heap was set to 0. They did not return NULL.

I would have expected the mallocs to fail ... (more)

69
views
no
votes
1
answer
Last activity 2017-08-17 14:24:14 +0200 by Nick Bentzen

SPI MOSI default high? NRF SDK 12.2.0

I am attempting to interface a Winbond flash device with the NRF52. The datasheet does not specify the idle state of MOSI when reading from the device. However, I cannot make the flash chip work with the NRF52. In the ... (more)

80
views
no
votes
1
answer
Last activity 2017-08-17 09:26:55 +0200 by tellg flag of Norway

SDK13 BDS error in bds_uint8_array_decode?

Hello,

I am just using the SDK13 on the nRF52832 together with the experimental BDS example (I modified it to the point where it seems to be working fine so far).

Now when using uint8-array as data-type for a writeable ... (more)

204
views
no
votes
no
answers
Last activity 2017-08-17 03:01:20 +0200 by strengthstrong

Question about setting ATT MTU size in S132 v4

Hello,

I find that some examples such as ble_app_uart uses a GATT_MAX_MTU_SIZE of 158, and it has initialization in function ble_stack_init().

// Configure the maximum ATT MTU.
memset(&ble_cfg, 0x00, sizeof(ble_cfg));
ble_cfg.conn_cfg.conn_cfg_tag                 = CONN_CFG_TAG;
ble_cfg.conn_cfg.params.gatt_conn_cfg.att_mtu ...
(more)

27
views
no
votes
1
answer
Last activity 2017-08-16 18:28:54 +0200 by Petter Myhre flag of Norway

ble_gap_data_length_params_t range

Hi

We are trying to port our app from softdevice v3.0.0 to softdevice v5.0.0. We note that the data length and bandwidth configuration procedure has changed drastically, including the introduction of the sd_ble_gap_data_length_update() function. My question ... (more)

29
views
no
votes
1
answer
Last activity 2017-08-16 12:15:50 +0200 by endnode

Role of Central's Tx Power in connection with Peripheral

How does the Tx power impact the scanning and connection with a peripheral?

In detail, say if the peripheral can advertise at a Tx power of 4, 0 or -4 dB, then will it depend on the central's maximum ... (more)

28
views
no
votes
1
answer
Last activity 2017-08-16 06:11:39 +0200 by RK flag of Singapore

BLE_ERROR_NO_TX_PACKETS

what is meaning of return value BLE_ERROR_NO_TX_PACKETS,when i use sd_ble_gatts_hvx() send data..

69
views
1
vote
1
answer
Last activity 2017-08-16 05:26:55 +0200 by Drewster

BLE_APP_UART Locks up with high datarate

I'm attempting to take a 115k baud stream of NMEA sentences from a GPS sensor, and outputting it to a phone based on the UART example. While I'm not sure if BLE is perfectly capable of handling it ... (more)

23
views
-2
votes
no
answers
Last activity 2017-08-16 02:24:54 +0200 by happykelvin

send data more fast [closed]

how to set the ble stack ,let the sd_ble_gatts_hvx() send data return more fast,now from i use sd_ble_gatts_hvx() to get the return (BLE_TX_COMPLETE) needed 300ms.

18
views
-1
votes
no
answers
Last activity 2017-08-15 13:51:29 +0200 by happykelvin

what facter will influence the speed of sending data [closed]

when use sd_ble_gatts_hvx() send data must need 300ms what facter will influence the speed of sending data ,please help me ,thank you very much

22
views
-1
votes
no
answers
Last activity 2017-08-15 12:43:56 +0200 by happykelvin

reduce send time [closed]

when i use sd_ble_gatts_hvx() send data , 300ms later the BLE_TX_COMPLETE is return ,why need so much time,how to reduce that time.

30
views
1
vote
1
answer
Last activity 2017-08-15 12:07:34 +0200 by endnode

how to do to change the TX_BUFFER size

how many byte of the s132 ble_stack_TX_BUFFER size ,if i can change the size and how to do to change the TX_BUFFER size

24
views
-1
votes
1
answer
Last activity 2017-08-15 11:21:44 +0200 by endnode

quickly get BLE_EVT_TX_COPLETE

when i use sd_ble_gatts_hvx() send data to ble stack, after 300ms later ,i get the ble stack event BLE_EVT_TX_COPLETE , how i can reduce the time(300ms), let the data send out more fast,and quickly get BLE_EVT_TX_COPLETE , because we must ... (more)

34
views
3
votes
no
answers
Last activity 2017-08-15 11:14:34 +0200 by ndarkness

Can I configure GPIOTE to debug my signals?

Hello,

I am using nrf52832 DK and I would like to use the GPIOs port to debug a couple of signals that I genereate within the MCU.

So far I have configured my GPIOTE module like this (I am using ... (more)

18
views
-1
votes
no
answers
Last activity 2017-08-15 11:11:15 +0200 by happykelvin

accelerate send package [closed]

how i can send data 1500byte per second,use the sd_ble_gatts_hvx(). because i send the first package use sd_ble_gatts_hvx() and 300ms later i get the BLE_EVT_TX_COMPLETE, the i send the second package, i want to reduce the time(300ms),let ... (more)

81
views
1
vote
no
answers
Last activity 2017-08-15 11:00:58 +0200 by Eliot Stock flag of United Kingdom

SDK 14 migration: can't advertise. fstorage busy.

Hi there.

I recently migrated from SDK 13 to SDK 14.0.0 and followed the migration guide in detail. I've found that when I try to advertise, ble_advertising_start() will find that fstorage is in use and bail out ... (more)

27
views
no
votes
no
answers
Last activity 2017-08-15 07:59:28 +0200 by xhr0428

Stop and restart APP_TIMER doesn't work with SDK12

I use an app_timer to periodically update sensor reading in my application. There is a characteristic used to change updating rate by stopping and restarting the app_timer:

app_timer_stop(m_our_char_timer_id);
app_timer_start(m_our_char_timer_id, APP_TIMER_TICKS(1000, APP_TIMER_PRESCALER), NULL); //1000ms

It works fine with ... (more)

32
views
-1
votes
1
answer
Last activity 2017-08-14 14:24:24 +0200 by RK flag of Singapore

one Thread use sd_ble_gatts_hvx() send many package

how to save a problem,if one Thread use sd_ble_gatts_hvx() send many package ,but i use vTaskDelay(50)( the freertos delay api ) when one package send ,then send another package . but
some packgae lost data .At the same time other ...
(more)

46
views
1
vote
1
answer
Last activity 2017-08-14 12:46:07 +0200 by Jørgen Holmefjord flag of Norway

What is the right factor to convert voltate using SAADC?

Hello,

I am getting really confused when using te SAADC to convert the read values into voltages.

I have seen that the example ble_app_proximity() uses the following macro

#define ADC_REF_VOLTAGE_IN_MILLIVOLTS     600
#define ADC_RES_10BIT                     1024   
#define ADC_PRE_SCALING_COMPENSATION      6   
ADC_RESULT_IN_MILLI_VOLTS(ADC_VALUE)\
        ((((ADC_VALUE ...
(more)

41
views
no
votes
2
answers
Last activity 2017-08-14 11:01:33 +0200 by madblue

applications to plot ecg through BLE

Is there any applications which can plot ecg from data send through BLE ?

13
views
no
votes
no
answers
Last activity 2017-08-12 05:38:12 +0200 by happykelvin

why haven't the BLE_GATTS_EVT_HVC return [closed]

if send data use sd_ble_gatts_hvx() ,why haven't the BLE_GATTS_EVT_HVC return

14
views
no
votes
no
answers
Last activity 2017-08-12 03:24:16 +0200 by happykelvin

p_ble_evt->evt.gatts_evt.params.timeout.src

when use the sd_ble_gatts_hvx() send data and printf() the value below

p_ble_evt->evt.gatts_evt.params.hvc.handle p_ble_evt->evt.gatts_evt.params.sys_attr_missing.hint p_ble_evt->evt.gatts_evt.params.timeout.src

use %d all the value is 17, i cann't what's meaning

36
views
no
votes
1
answer
Last activity 2017-08-11 13:16:31 +0200 by Sigurd flag of Norway

how to increase Piezo buzzer sound

We are trying to modify SDK example pwm_library, we are able to generate minute sound ,how to increase the sound

11
views
no
votes
no
answers
Last activity 2017-08-11 11:36:31 +0200 by happykelvin

how to save sending package lost data [closed]

how to save a problem,if one Thread use sd_ble_gatts_hvx() send many package ,but i use vTaskDelay(50)( the freertos delay api ) when one package send ,then send another package . but
some packgae lost data .At the same time other ...
(more)

9
views
no
votes
no
answers
Last activity 2017-08-11 11:24:44 +0200 by happykelvin

how to save sending package lost data [closed]

how to save sending package lost data,when use sd_ble_gatts_hvx() send data

45
views
no
votes
1
answer
Last activity 2017-08-11 11:23:56 +0200 by Hung Bui

nrf52832 S132 bonding

SDK: nRF5_SDK_11.0.0
Softdevice: s132_nrf52_2.0.0_softdevice

I read an article about the connection, pairing, bonding and whitelist, there are some doubts:

Bonding: Paired devices can be bonded. This means that they store the keys that have already been ... (more)

12
views
no
votes
no
answers
Last activity 2017-08-11 11:13:41 +0200 by happykelvin

which package lost [closed]

my programer have many place use sd_ble_gatts_hvx() send data , if i get the BLE_GATTS_EVT_HVC ,how i know this return value return belong which use sd_ble_gatts_hvx(),how i know which data package lost

Statistics

  • Total users: 23749
  • Latest user: Janet Whitworth
  • Resolved questions: 10099
  • Unanswered questions: 3093
  • Total questions: 24490

User menu

    or sign up

Recent questions