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1. Introduction 
 
The EYSHxN module comes with the Nordic’s nRF52832 Bluetooth Low Energy 5(BLE5) 
module. For ease of programming this module, Nordic has released its SDK (Software 
Development Kit).  To develop Bluetooth Low Energy, there are self-contained BLE static 
library stacks for ease connection to the API, these are called SoftDevices. 
 

 
Figure  1  Software layout of nRF52832 

 
To use the “SoftDevice”, in the place of the device static memory, the static library is used. The 
SoftDevice is programmed to the module’s flash memory before the user application. If the 
Softdevice is being used it will be shown in the memory layout as shown below. 
 

 
Figure 2  Typical Memory Layout of nRF52832 
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2. About this Quick Start Guide 
 
This quick start guide will show how to install the developing environment used to program 
the BLE UART application on the Taiyo Yuden EYSHxN module, using the Nordic’s nRF SDK. 
  
On this guide, we will be focusing on using the free version of the Keil IDE with the” No-Packs” 
(zip)version. Using the “No-packs” version of the SDK makes it easier to understand the SDK 
layout, as well as to change between the SDK versions, since it keeps the whole SDK in a single 
folder. 
 
The needed things are as follows: 
 

- Internet Connection 
- Windows PC 
- EYSHxN Board 
- ARM Cortex M-9 Compatible Programmer（For example: J-Link Lite CortexM-9 JTAG/SWD 

Emulator） 

- An Android or iOS device for testing 
- Serial Terminal Software（For example: Termite, TerraTerm, RealTerm） 

 
In the next steps, we will focus on explaining the different steps for developing the EYSHxN 
board: 
 

 Installing the IDE 
 Installing the NRF stack 
 Setting the BLE UART Project 
 Programming the SoftDevice 
 Executing the samples 

3. Software Needed 
 
Including IAR, GCC and Keil, there are many developing environments that can be used to set 
up the EYSHxN module. 
 
The recommended tools for testing the developed firmware on the EYSHxN module are as 
follows. 
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Table 1 Software Needed 

4. Installing the IDE 
 
Keil uVision IDE (MDK-ARM) is available to download in the Keil’s Homepage 
(http://www.keil.com). From the time that this guide is written, the download is available 
here: 

 
Downloads->Product Downloads->MDK-ARM 

 
Registration is needed. 
Start Keil uVision installer. The first time, the window showed on Figure 3”Pack Installer” will 
appear. 
 

Caution: The Pack Installer will automatically open as soon as the MDK-ARM installation is 
finished. 
 

Caution: If after the IDE starts and the Pack Installer is not automatically started, go to 

Project -> Manage -> Pack Installer or press the  icon on the main menu to open. 
 

Tool Name Used For Download From 
KeiluVisionIDE  
(MDK-ARM) 

Developing and programming 
the firmware application 

Keil’s Homepage(www.keil.com) 

nRFGo Studio To control the flash memory. 
To program the Softdevices 
and Bootloaders 

Nordis’s Homepage 
(www.nordicsemi.com) 

Nordic  nRF52 SDK 
(For BLE5, it needs 
to be 14 or over) 

It offers easier ways to control 
the hardware abstraction and 
support of the libraries for the 
nRF52832 module. 

Nordic’s Developers Homepage 
(http://developer.nordicsemi.com) 
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Figure 3 Keil Pack Manager 

 
By pressing  or in the menu File -> Refresh Packs, the selected available Packs will update. 
If Refresh Packs is not available for selection, it might be possible that the update is already in 
progress or the system is offline. Confirmation can be seen on the bottom left corner of the 
window.  
 
For the “No Packs” Nordic SDK Version in the settings, the only pack needed to be downloaded 
is the “Device Family Pack” which adds the nRF series devices to the Keils target database. 
(There are other ways to download the “Device Family Pack” but this is the easiest and safest 
way to obtain the latest target information.) 
In the contents of the “Devices”, click on the “Nordic Semiconductor” and select install on the 
“NordicSemiconductor::nRF_DeviceFamilyPack”. 
After the installation is complete, the “Install” icon will change to “Up to date” as shown in the 
next figure. 
 
 

 
Figure 4  Installing the Keil Pack 

 
Please do not install other packs. The other files are all included in the downloaded “No Packs” 
SDK. 
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5. Installing nRFGo Studio 
 
In the Nordic Semiconductor homepage(http://www.nordicsemi.com), download the nRFGo-
Studio. 
 
The nRFGo-Studio download can be found in the” Downloads” in RF52832 product page. 
The installer comes with nRF-Tools, which includes additional support for other debuggers. 

6. Installing the nRF52 SDK 
 
The latest version of the nRF52 SDK can be directly downloaded from Nordic Developer’s 
Website (http://developer.nordicsemi.com). The SDK are shown on top of the page. 

For BLE5, please download SDK14 and above (Latest) 
 

 
Figure 5  Nordic’s Developers Website 

 
On the time this guide was created, the latest version of the” no packs” SDK can be downloaded 
from here: 
 

nRF5_SDK -> nRF5_SDK_vx.x.x -> nRF5_SDK_X.X.X_yyyyyyy.zip 
 
 
The x is the SDK version. 
 

Caution: This guide is focused on” no packs”. Please do not download the” 
packs” SDK version. 

 
Unzip the folder in your working directory. If a Japanese PC is being used, please avoid using 
Japanese named paths. (For example: C:\Nordic52SDK） 
 

Caution: The SDK installer inside the unzipped folder is not needed for the 
environment so it can be removed without any problem. Please do not 
execute it. 

 
After this point in the guide, the location of the SDK is “sdkroot”. 
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7. Programming the SoftDevice 
 
The BLE UART Demo uses the S132 BLE SoftDevice. This needs to be programmed to the 
module before the actual application. 
To start, connect the EYSHxN Board to the PC. 
 

Caution: The programmer doesn’t power the EYSHxN board. To power the 
board, please connect it through Mini-USB. 

 

 
Figure 6  Using nRFGo Studio to program the SoftDevice 

 
1.  Start nRFGo Studio, on the left menu select” nRF5x Programming”. 
 
2.  Delete the device’s whole memory. 
 
3.  Make sure that the “Program SoftDevice” tab is selected, in” Browse” please refer to the 

SoftDevice. Use S132 SoftDevice as shown below: 
 

sdkroot/components/softdevice/s132/hex /s132_nrf52_X.X.X_softdevice.hex 
 

 Or from the Nordic Semiconductor nRF52832 product page, the latest S132 SoftDevice is 
available for download. 

 
4.  Click “Program” to program the SoftDevice into the module. 
 
nRFGo studio displays the current memory map of the SoftDevice installed at the bottom and 
the application area directly above it. 
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8. Setting up the BLE UART project 
 
All the nRF51 SDK project files are set up for PCA10040 developer board. The easiest way to 
use the sample for the EYSHxN board is using the PCA10040 project and modify it to be used 
on the EYSHxN. 
 
In the place below, open the SoftDevice S132 no packs BLE UART sample project: 
 

sdkroot/examples/ble_peripheral/ble_app_uart/pca10040/s132/arm5_no_packs 

 
 

8.1. Setting up the EYSHxN target 
 

In the main window click the  icon and as shown below, create a new target name: 
Project->Manage->Project Items 
 

Pressing on  adds a new target name. Call it “taiyoyuden_EYSHxN_S132” and click on” 
Set as Current Target”. 
 
As Figure 7 shows, the target folder and the drop-down will show” 
taiyoyuden_EYSHxN_S132”. If it doesn’t show, please select it on the drop-down menu. 
 

 

 
Figure 7  Setting the new Target Setting up the target device 

8.2. Settings for Target Device 
 

As explained in 8.1, after confirming that” taiyoyuden_EYSHxN_S132” settings are selected, 

in the main window click the  icon or open the target options as shown: 
 

Project -> Options for target taiyoyuden_EYSHxN_S132 
 
In the “Device” tab select nRF52832xxAA. 
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Figure 8  Target Device Options 

 

8.3. Setting up the target options 
 
In the “Target” tab change the Xtal(MHz) to 64.0. 
 
Next, it’s necessary to restrict the IDE’s chip code memory(flash) and RAM (See Figure 2) 
for the application. The exact settings depend on application’s environment (SoftDevice 
Version, Bootloader, and other static libraries). In this case, as S132 SoftDevice is used, the 
chip’s remaining memory is freely used by the application. 
 
The SoftDevice ROM and RAM size usage, it’s described on the specifications depending on 
the version of SoftDevice. The start of the application area is indicated as APP_CODE_BASE 
and APP_RAM_BASE. 
 
nRF52832’s flash code memory address starts at 0x00000 and the size is 512kb(0x80000)/ 
The RAM starts in the address 0x20000000 and the size can be up 64kb(0x4000). 
 
Figure 9 shows memory settings of the application using 64kb RAM module (EYSHxNZWZ) 
and SoftDevice S132 v5.0.0.  This SoftDevice uses 0x2300 of flash memory and 0x20002800 
of RAM. 
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Figure 9  Target Memory Options 

 
Caution: If memory settings are incorrect the application will not run correctly.If 
using different SoftDevice versions, the ROM and RAM values will be different. 
Always check the memory setting of the SoftDevice from the SoftDevice 
specification and the appropriate IDE memory area. 

 

8.4. Setting up the debugger 
 

In the “Debug” tab, change the debugger using the drop-down menu to the debugger 
currently in use. 
 
As Figure 10 shows,” J-Link Lite” debugger has been selected. 

 
Figure 10  Target Debugger Options 
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9. Overview of BSP 
 
When using IO or peripherals, the nRF52 SDK uses preprocessor pin definitions so 
transferring to different modules becomes an easier task. 
All the pin configurations are contained in the” Board Support File” (bsp), so it can be easily 
adjusted depending on the hardware. The starting SDK sample is set up for the PCA10040 
board. To use the EYSHxN module pin configurations need to be adjusted. 
 
Before executing most of the SDK peripheral samples, pins for the EYSHxN need to be adjusted. 
 

9.1. Setting up the custom ports for each project 
 

A file called “custom_board.h” can be created in the project directory for your custom board. 
In this example, we will create the “custom_board.h” file in following location: 

 
sdkroot /examples/ble_peripheral/ble_app_uart/pca10040/s132/arm5_no_packs/RTE 

 
Using Keil IDE to add the file, use the following procedure. 
 

①    Right click on the「Board Support」folder 

②    Choose「Add New Item to Group Board Support」 

 

Figure 11 Create Board Support  

 
After creating the Board Support File, the pins used on the BLE UART Sample need to be 
defined. 
 
The Mini-USB connector on the EYSHxN development board, includes TTL-UART. To use 
the UART through the connector, pins need to be set as shown in Table 2. 
 
Caution: If other functions（LED、SPI）are needed, pins need to  defined per design. 
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Hint: EYSHxN’s through hole pitch, it’s compatible with the standard breadboard’s 
solderless prototyping. 

 
Define Name Function Pin 
RX_PIN_NUMBER   UART Receive  8 
TX_PIN_NUMBER   UART Transmit 6 
CTS_PIN_NUMBER UART CTS 7 
RTS_PIN_NUMBER UART RTS 5 

Table 2 Settings for BLE UART demo 

The header file of the “custom_board.h” is as shown. 
In addition, pin 25 is defined as the LED and pin 24 as the button. The board itself does not 
contain a button or and LED, to use these, please connect LED or button respectively. 
 

 
Figure 12  Defining pins for the board 

 
Once the custom board file is created, the global preprocessor definition used by the board 
support system needs to be changed to” BOARD_CUSTOM”.  
 

As 8.1 explained, ensure that the target is set to” taiyoyuden_EYSHxN_S132”, click the  
icon in the main window and open the target options: 
 

Project -> Options for target taiyoyuden_EYSHxN_S132 
 
On the "C/C++" tab, as shown in Figure 13 change the"BOARD_PCA10040" to 
"BOARD_CUSTOM". 
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Figure 13      Defining the Global Board Settings 

 
For more information on how to use board definitions see 
sdkroot/ components/boards /boards.h file and the "BLE Development Manual". 

 

9.2. Adding the custom board for the SDK 
 

Instead of creating a” custom_board.h” for each project, you can permanently add your own 
board to the future SDK projects. Details will not be explained in this Start Up Guide. Please 
refer to the “BLE development manual” for more information.  
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10. Executing the Sample 
 

Connect the programmer to both the PC and the EYSHxN board, and at the same time connect 
the EYSHxN board to the PC through the Micro-USB.  
 
Connect the GCN board and the Micro USB connector of the EYSHxN board to the PC. 
 
When connected, the EYSHxN board will appear in the “Device Manager” as” USB Serial Port”. 
The way to open the device manager window depends on the Windows version and will not be 
explained on this Quick Start Guide. 
 

 
 Figure 14     Confirming the EYSHxN COM Board 

 
Caution: If the EYSHxN is not shown correctly, please download the 
FT232RG driver from the FTDI website. 
(http://www.ftdichip.com/Drivers/D2XX.htm) 

 

The project will be compiled if this  icon is pressed or and following the bottom menus are 
followed. 
 
Project -> Rebuild all target files 
 

To download the compiled application into the module, press this  icon or follow the steps 
below through the menus. 
 
Flash -> Download 
 
The code is downloaded to the module and executed. 
 

Caution:  If the error message ”Error: Flash download failed – Cortex-
M4”appears, the SoftDevice memory options are not set correctly. Please 
refer to chapter  7. 

 
 

To test the program, connect the terminal software（TerraTerm、RealTerm、Termite）to the 
EYSHxN COM Port with the settings shown below. 
 
 

Specification Value 
Baudrate 115200 
Parity None 
Data Bits 8 
Stop Bits 1 

Table 3 Serial Settings for BLE UART demo 
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After connecting to the terminal software, download” nRF Toolbox” application from the App 
Store or Play Store (iOS or Android) to the tester mobile device. 
 
Open “nRF Toolbox” application, select” UART” demo and click “CONNECT” to discover the 
device. Select” Nordic_UART” and once connected all button operations will send signals to the 
EYSHxN module through BLE and will be displayed as text in the terminal software. 
 

 
Figure 15  Connecting the BLE Module 
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