0

Can I use master control panel with a non offical usb dongle board ?

MustafaFayez gravatar image

asked 2017-03-20 18:36:08 +0100

I have an after market breakout board for nrf51822 with a usb-to-serial chip (cp2102) that I bought from Amazon. It should act as an NRF51 USB dongle (pca10031-like) but with half the price.

I managed to flash the MEFW on it successfully using nrfgo studio and the official nrf51dk debug out feature, but I wasn't able to use MCP with it. It keeps saying: No response from master emulator

image description

I've tried different versions of MEFW with different baud rates. but nothing worked

Note: that breakout board doen't have segger J-Link debugger chip, will that be a problem in it being detected and used by MCP. from my understanding it should not be a problem.

edit retag flag offensive close delete report spam

1 answer

Sort by ยป oldest newest most voted
2
hungbui gravatar image

answered 2017-03-21 13:44:17 +0100

updated 2017-03-21 13:45:00 +0100

@Mustafa: It nRFMCP should work with any board that have correct UART pins. Which pins on the nRF51 on the board was used for UART RX and TX pins ?

Were them match with what on the nRF51 dongle board (e.g PCA10031)?

Note that we have a small trick that we mount P0.30 to ground to tell the chip that it's the newer dongle (not the very old one we made 3 4 years ago). So you may need to mount the pin to ground also.

edit flag offensive delete publish link more

Comments

@Hung, if the pins you mentioned are connected to RX and TX correctly, what are the steps to do to be able to use nRF MCP with this unofficial board?

Mustafa ( 2017-03-21 15:31:48 +0100 )editconvert to answer

I don't think we have any check if it's Nordic board or not. If you can communicate with the board via UART then you should be able to use the MEFW firmware. Could you please tell the UART pins you used ? I am not 100% sure but most likely we used hardware flow control so 4 pins needed. have you connected P0.30 to ground ?

Hung Bui ( 2017-03-21 17:00:04 +0100 )editconvert to answer

Actually, pin 0.30 isn't connected to ground in this board. so, is there a fix other than connecting the pin 0.30 to gnd? because i don't have access to this pin.

Mustafa ( 2017-03-21 17:42:01 +0100 )editconvert to answer
1

If you don't have access to P0.30, you would need to connect the UART pin as on PCA10000:

P0.00 - CTS

P0.01 - RX

P0.02 - RTS

P0.03 - TX

Hung Bui ( 2017-03-22 10:00:35 +0100 )editconvert to answer

And what if they are not connected as you mentioned? I don't have access to these pins as well and they are not connected the same way as pca10000

Mustafa ( 2017-03-22 10:40:15 +0100 )editconvert to answer

These are the uart pins connections of my board:

P0.08 - CTS

P0.09 - RXd

P0.10 - RTS

P0.11 - TXd

These are the same as pca10031 but p0.30 isn't connected to gnd. what are my options?? thanks

Mustafa ( 2017-03-22 14:00:03 +0100 )editconvert to answer
1

I would suggest to manually solder a small copper wire to pin P0.30 and mount it to ground. Or better buy a new nRF52 DK or nRF52840DK. It useful for your future project, they support Bluetooth 5.0, long range , high bandwidth etc. They are $39. A couple of bucks saving isn't worth the hassle :)

Hung Bui ( 2017-03-22 15:01:07 +0100 )editconvert to answer

I managed to get a breakout of nRF51822 and an FTDI USB serial board with flow control, I did as you told me;

P0.30 to GND, and the UART connections you mentioned in your comments, however, it didn't work ( MCP didn't find master emulator).

What am I missing here?

note: I am using raytac 3rd party nrf51822 ble board and i have access to all pins.

update: my unofficial board doesn't contain the external 32.768khz crystal that is in the pca10000/10031 dongle, is this the reason it didn't work?

Mustafa ( 2017-03-22 16:24:13 +0100 )editconvert to answer

Yep, it doesnt have the crystal, it won't work. The firmware is tailor made for the PCAxxxxx so you need to make your board exactly the same configuration.

Hung Bui ( 2017-03-23 09:48:44 +0100 )editconvert to answer

by "exactly the same configuration" you mean even the segger-supported hardware (j-link support)? because I just have a USB-to-serial chip as I mentioned in the question.

Mustafa ( 2017-03-23 11:45:57 +0100 )editconvert to answer

No, only the GPIO connection (the UART's pins and P0.30), and the 32kHZ crystal .

Hung Bui ( 2017-03-23 17:56:37 +0100 )editconvert to answer

Ok, i will connect the clock, and let you know what happens. Thank you.

Mustafa ( 2017-03-23 18:44:25 +0100 )editconvert to answer

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer. Do not ask a new question or reply to an answer here.

[hide preview]

Question Tools

1 follower

Stats

Asked: 2017-03-20 18:36:08 +0100

Seen: 112 times

Last updated: mars 21