Error 22 GATT_CONN_TERMINATE_LOCAL_HOST

work_zcmm gravatar image

asked 2017-04-19 12:35:46 +0200

updated 2017-04-24 10:32:30 +0200

Hi,all SDK:8.1.0 51822 S7 Edge(android V7.0)

i use the sumsung S7 Edge and the oppo R9S connect with my device,nRF Connect is often note:

GATT_CONN_TERMINATE_LOCAL_HOST(after discovery all service ).

And the oppo R9S,it ofter note: Error34(0x22):GATT CONN LMP TIMEOUT(after discovery all service ).

what is problem?

and what error for picture as follow when discovery service? image description Attribute not Found.pcapng

edit retag flag offensive close delete report spam

Comments

Have you seen this? It is difficult to say what is happening without a Sniffer trace.

Petter Myhre ( 2017-04-20 13:27:37 +0200 )editconvert to answer

It seems the slave is not responding? Could you upload the complete sniffer trace please?

Petter Myhre ( 2017-04-21 12:59:19 +0200 )editconvert to answer

sorry,Sniffer also can not display packet data after connecting,so i can get complete sniffer trace,how to solve it? i sniffer it,the file is Attrbute not Found

zcmm ( 2017-04-24 10:22:41 +0200 )editconvert to answer

What do you mean? The sniffer trace you uploaded includes transactions after connection establishment. And the link is kept alive for the complete trace. What application are you running on the nRF51822? Can you share your complete project so I can test it here?

Petter Myhre ( 2017-04-25 09:05:06 +0200 )editconvert to answer

i mean i can not ofter sniffer complete trace,it is often loss a lot of connection data. the project is based on HRM_s110.do you want to see attribute question or nrf connect rsponse error?

zcmm ( 2017-04-25 12:42:32 +0200 )editconvert to answer

Why can't you do a complete sniffer trace? Are there two projects? Please just tell me how to reproduce the problems(s) you have.

Petter Myhre ( 2017-04-25 12:45:41 +0200 )editconvert to answer

sniffer question,pls see link text for GATT_CONN_TERMINATE_LOCAL_HOST,using sumsung S7 Edge and nrf connect app often connect with device,it will note this error.
for GATT CONN LMP TIMEOUT,i can not often repeatly get this error. for attribute not found,it often appear,maybe it is my sniffer device question?

zcmm ( 2017-04-25 12:52:04 +0200 )editconvert to answer

If your sniffer doesn't work, can you please share your complete project so I can test it here? Please tell me how to reproduce.

Petter Myhre ( 2017-04-25 13:56:34 +0200 )editconvert to answer

ok.how to send you private?

zcmm ( 2017-04-26 05:49:22 +0200 )editconvert to answer

Open a case through your MyPage at nordicsemi.com. You can share it privately there. But I don't have Oppo R9S or Samsung S7 Edge to test with, so if you are able to do a sniffer trace that would be best. Does this also happen with the unmodifed HRM example from the SDK?

Petter Myhre ( 2017-04-26 09:21:54 +0200 )editconvert to answer

ok,i will use a good sniffer tools,then give you a sniffer trace.S7 Edge is G935T,but the G9350 have not this question,it is very strange.do you know this question link text?

zcmm ( 2017-04-26 11:39:36 +0200 )editconvert to answer

hi,petter Myhre,my sniffer tool is normal rather than bad.i use another sniffer tool,it is not often sniffer complete trace.pls see this link log link text

zcmm ( 2017-04-27 12:43:43 +0200 )editconvert to answer

You are making me very confused. Please explain one problem, with which phone. And upload a sniffer trace that captures that problem here. Try to make the sniffer trace shorter than 200000 lines. Please edit your original question, explain and upload sniffer traces.

Petter Myhre ( 2017-04-28 12:47:10 +0200 )editconvert to answer