0

Cannot restart advertising in Beacon example [closed]

F0cks gravatar image

asked 2017-04-21 16:46:54 +0200

updated 2017-04-21 16:50:42 +0200

Hey guys!

I face a problem that I have not been able to solve since several days...

I would like to send only one advertising frame every 4 seconds. I do not want to use connectable mode since I only need to send few values periodically, and I do not need to get any answers. So I have modified "ble beacon example", which appears to be the best starting point for my project.

I have set interval and timeout like this:

#define APP_CFG_NON_CONN_ADV_TIMEOUT    1
#define NON_CONNECTABLE_ADV_INTERVAL    MSEC_TO_UNITS(2000, UNIT_0_625_MS)

Normally I send a frame every 2 seconds, but with the timeout of 1sec, I only send 1 frame and the advertising stops.

I have set a timer every 4 seconds that launches the function "advertising_start()".

It works once. In the main loop, I launch once "avertising_init()" and when the timer reaches 4 seconds, it launches "advertising_start()". However, the next 4 seconds, my board seems to reset. I have enabled nRF_log, and when the timer uses again "advertising_start()" I can see:

APP_ERROR:ERROR:Fatal

Considering this post, I am stopping correctly the advertising. And with this one, it seems that I am restarting it correctly.

I need help to find what I am doing wrong... :D

Thanks for your help!

edit retag flag offensive reopen delete report spam

Closed as "the question is answered, right answer was accepted" by F0cks at 2017-04-26 07:28:18 +0200

Comments

I don't understand why you are stopping advertising. Just don't set the connectable flag in the advertisment, then it's not connectable and start ble advertising in the softdevice for 4 sec duration. And just let it go. After that it is running as a beacon only with 4 sec between advertisement bursts. No need to mess with it. If you want to alter the advert data on the fly, just modify the struct values that the init routine looks at then run advertising_init and the values get passed over to the softdevice. Again, no need to stop it.

AmbystomaLabs ( 2017-04-21 17:36:40 +0200 )editconvert to answer

My problem is not how to send advertising signal every 4 sec but how to stop and restart it... I have power management considerations and I need to stop it. I also know how to change data on the fly and how the non connectable mode is working. Thanks for your answer but it does not help me.

F0cks ( 2017-04-21 18:30:22 +0200 )editconvert to answer

Hey! That is what I am planning to do: compare which mode consumes more power. To see if there is more or less average power used by spikes when I turn on BLE compared to let it always turn. I have seen your solution in other posts, but I have not tried it because some people say that it has strange behavior. But you have convinced me and for the moment, I do not see any side effect and I do not have "Fatal error" or reset anymore. Thanks a lot for your help!

F0cks ( 2017-04-24 11:20:59 +0200 )editconvert to answer

1 answer

Sort by » oldest newest most voted
0
AmbystomaLabs gravatar image

answered 2017-04-21 20:13:42 +0200

F0cks gravatar image

updated 2017-04-24 11:21:26 +0200

Oh, I get it. I've always used:

                            err_code = sd_ble_gap_adv_stop();
                        APP_ERROR_CHECK(err_code);

And then:

                            err_code = sd_ble_gap_adv_start(&m_adv_params);
                        APP_ERROR_CHECK(err_code);

So, far it's worked every time I have used it. Though if you are on a newer SDK, then the API's might have changed. But if they did, Nordic are pretty good at describing the API changes in the release notes.

But from experience, I can tell you that the code executed to stop and start advertising is vastly more power hungry than a few beacons. So you need to be turning it off for quite a while to make it worth it on power consumption.

edit flag offensive delete publish link more

Question Tools

1 follower

Stats

Asked: 2017-04-21 16:46:54 +0200

Seen: 34 times

Last updated: Apr 21