0

dnsmasq in border router error

edward.mcl gravatar image

asked 2017-06-19 11:45:33 +0200

I'm trying the example border router using 2 x nRF52840 boards one with CLI and the other with NCP connected to a PI. I can get ipv6 addresses and get them to ping each other but can't get a 2001 ip address (no internet connectivity). Looking at the system log for Openwrt I see the router fails to start the dnsmasq service with the error 'failed to create listening socket for port 53: Address in use'. So there is a conflict on port 53 between bind named which has already started and dnsmasq. How do I fix this?

edit retag flag offensive close delete report spam

2 answers

Sort by » oldest newest most voted
1
pisz gravatar image

answered 2017-07-17 13:14:29 +0200

updated 2017-07-17 15:49:56 +0200

Hi Edward,

Thank you for your interest in the Thread Border Router. The error you see does not influence the behavior of the Border Router itself. Something else must be causing the connection issues you experienced.

Please let me know if you work with the latest version of the SDK and the BR image https://www.nordicsemi.com/eng/Produc... which are 0.10.0 and 0.10.0-1.alpha respectively.

Do you connect the Raspberry to the Local network via Wi-Fi or wired connection?

I see that you do not get a native IPv6 address. What about the IPv4? Did you follow the Thread Border Router chapter in our documentation? Were you able to ping the Google DNS using IPv4? (ping fd00:0064:0123:4567::0808:0808)

Sorry for posting so many questions. The case is that we need a more information to solve the issue.

Kind Regards, Piotr Szkotak

edit flag offensive delete publish link more
0
edward.mcl gravatar image

answered 2017-07-25 17:55:46 +0200

updated 2017-07-26 17:13:16 +0200

I get this from dns resolve

dns resolve ipv4.google.com fd00:0064:0123:4567::1

DNS response for ipv4.google.com - Error 30: ResponseTimeout

and this from ifconfig on BR eth0 Link encap:Ethernet HWaddr B8:27:EB:5E:13:8E
inet addr:192.168.1.40 Bcast:192.168.1.255 Mask:255.255.255.0 inet6 addr: fe80::ba27:ebff:fe5e:138e/64 Scope:Link UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:30075 errors:0 dropped:17728 overruns:0 frame:0 TX packets:669 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:6333320 (6.0 MiB) TX bytes:89924 (87.8 KiB)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0 inet6 addr: ::1/128 Scope:Host UP LOOPBACK RUNNING MTU:65536 Metric:1 RX packets:17197 errors:0 dropped:0 overruns:0 frame:0 TX packets:17197 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1 RX bytes:1374961 (1.3 MiB) TX bytes:1374961 (1.3 MiB)

tayga-nat64 Link encap:UNSPEC HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
inet addr:192.168.64.1 P-t-P:192.168.64.1 Mask:255.255.255.255 inet6 addr: fd00:64:123:4567::1/128 Scope:Global inet6 addr: fd00:64:123::/64 Scope:Global inet6 addr: fd00:64:123::1/128 Scope:Global UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1500 Metric:1 RX packets:0 errors:0 dropped:0 overruns:0 frame:0 TX packets:1 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:500 RX bytes:0 (0.0 B) TX bytes:76 (76.0 B)

wlan0 Link encap:Ethernet HWaddr B8:27:EB:0B:46:DB
inet addr:192.168.2.1 Bcast:192.168.2.255 Mask:255.255.255.0 inet6 addr: fe80::ba27:ebff:fe0b:46db/64 Scope:Link UP BROADCAST RUNNING MULTICAST MTU:1400 Metric:1 RX packets:0 errors:0 dropped:0 overruns:0 frame:0 TX packets:7 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:0 (0.0 B) TX bytes:986 (986.0 B)

From PI ping 8.8.8.8

PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.

64 bytes from 8.8.8.8: icmp_req=1 ttl=57 time=45.5 ms

From CLI

ping fd00:0064:0123:4567::0808:0808

ipaddr

fdde:ad00:beef:0:0:ff:fe00:3400

fe80:0:0:0:10aa:3eb:55b3:7ab7

fdde:ad00:beef:0:af6e:c9d3:6ab5:d060

Done

You are correct the cable from the RPi to the NCP was faulty so now I can ping fd00:0064:0123:4567::0808:0808 from a node. But the RPi seems a bit flaky in starting wpantund.

Thank you Piotr

Maybe wpantund is a bit slow in starting, I'll see how it goes and again many thanks for resolving this.

edit flag offensive delete publish link more

Comments

We need to make sure if there is a problem with the DNS or you do not have any connectivity between the CLI and the BR. Please log the following:

Two commands from the CLI: 1)ping fd00:0064:0123:4567::0808:0808

2)ipaddr

From the RaspberryPi: ping 8.8.8.8

Piotr Szkotak ( 2017-07-26 13:26:49 +0200 )editconvert to answer

You see that the RPi can ping the Google DNS server, but the CLI cannot - It does not seem have connection to the Border Router. Please let me know if you have followed the procedure described in the Thread Border Router Getting Started section: http://infocenter.nordicsemi.com/inde...

If you did not modify Thread Network parameters (channel, panid, masterkey and so on in the file /etc/config/thread_border_router) please restart the CLI and execute the following commands:

1) panid 0xabcd 2) ifconfig up 3) thread start 4) state 5) ping fd00:0064:0123:4567::0808:0808

if you still fail to ping fd00:0064:0123:4567::0808:0808 please collect the following:

From the RPi: 1) wpanctl status 2) wpanctl getprop

From the CLI: 1) state 2) ipaddr 3) channel 4) panid 5) extpanid 6) masterkey 8) router table

Piotr Szkotak ( 2017-07-26 16:02:59 +0200 )editconvert to answer

I'm happy to see that it is working now. What do you mean by "flaky"? If you have some delay on mind it is expected as we need to have the OS fully booted, perform initial setup and then start the wpantund daemon itself.

Piotr Szkotak ( 2017-07-26 17:08:59 +0200 )editconvert to answer

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer. Do not ask a new question or reply to an answer here.

[hide preview]

User menu

    or sign up

Recent questions

Question Tools

2 followers

Stats

Asked: 2017-06-19 11:45:33 +0200

Seen: 101 times

Last updated: Jul 26