0

NRF Snifffer 1.0.1 problem

MaxSinton gravatar image

asked 2017-08-10 10:54:48 +0100

updated 2017-08-10 20:08:05 +0100

Hi,

I am using ble-sniffer_nRF51822_1.0.1_1111_Sniffer.hex as the sniffer and I am trying to see all ble beacons. Because I have many beacons about (100 in one second) I decided to set the ble becons to transmit on one channel. 30 PCs transmit on channel 37. 30 PCs transmit on channel 38. 40 PCs transmit on channel 39.

When all beacons(channel 37,38 and 39) are in the read range of the sniffer, the sniffer will send me the packet over the serial. But when there are just one channel beacons for example only channel 37 beacons are in the read range of sniffer. in this case, the sniffer will not send me any packet and I just get the ping data from serial. When I put one beacon of channel 38 and one beacon of channel 39 then I will get all beacons packet. It seems that the sniffer works when it sees data on all 3 channels.

Is this the sniffer firmware bug? What should I do?

edit retag flag offensive close delete report spam

1 answer

Sort by ยป oldest newest most voted
0
hungbui gravatar image

answered 2017-08-11 11:12:27 +0100

updated 2017-08-11 11:15:11 +0100

Hi Max,

This is because the sniffer can't listen to all 3 channels at the same time (simply because it has only one radio). So it must use a hopping pattern. By default the hopping is 37 38 39. You can change that to set to only one channel, 37 for example.

Note that even though your beacons transmit on different channel, if they transmit at the same time and if they are close enough (signal strength strong enough) to the receiver they will still cause interference.

edit flag offensive delete publish link more

Comments

Hi Hung,

Thank you for your reply. You are right, But my problem is that the sniffer will be paused on the empty channel. When I am using all beacons on channel 37, the sniffer will not see any thing. I think the problem is that the sniffer will stay in channel 38 because it is empty and no beacons transmit on this channel. (Is this the firmware bug?)

How can I tell the sniffer to listen on only one channel?

MAX ( 2017-08-12 06:44:17 +0100 )editconvert to answer

Yes, you can change the hopping pattern to listen on only one channel. Press "h" in the sniffer console to select the channel you want to follow.

Hung Bui ( 2017-08-14 09:47:28 +0100 )editconvert to answer

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer. Do not ask a new question or reply to an answer here.

[hide preview]

Question Tools

1 follower

Stats

Asked: 2017-08-10 10:54:48 +0100

Seen: 80 times

Last updated: aug. 12