0

how to disable fpu on freertos nrf52 project

liudijiang gravatar image

asked 2017-08-11 11:01:23 +0200

I use blinky_freertos demo on nrf52832,

now I want to disable FPU, but when I disable FPU in Keil MDK option->Target Floating Point Hardware Not Used, there is an error

#error This port can only be used when the project options are configured to enable hardware floating point support.

how to fix this error ? thx!

edit retag flag offensive close delete report spam

1 answer

Sort by » oldest newest most voted
0
rols gravatar image

answered 2017-08-12 04:29:43 +0200

You can't. That port was done with the expectation there's an FPU and it's enabled, hence the error message if you don't enable it. If you want to use it without FPU support, you'll need to change the port or port it yourself.

edit flag offensive delete publish link more

Comments

@liudijiang: Could you explain why you want to disable the FPU?

Bjørn Spockeli ( 2017-08-14 13:25:03 +0200 )editconvert to answer

FPU cost more current. we try to save more power, because the device is supported by battery @Bjørn Spockeli

liudijiang ( 2017-08-17 07:10:15 +0200 )editconvert to answer

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer. Do not ask a new question or reply to an answer here.

[hide preview]

Question Tools

1 follower

Stats

Asked: 2017-08-11 11:01:23 +0200

Seen: 34 times

Last updated: Aug 12