segger embedded studio build error

Yacire93 gravatar image

asked 2017-08-11 17:07:05 +0100

Hi NordicSemiconductor Community,

I have a problem with the SEGGER Embedded Studio IDE, i want to build my project but i have the following error :

can't open 'C:/Users/Yacire/Desktop/NORDIC_SEMICONDUCTOR/nRF51_SDK_10.0.0_dc26b5e/examples/ble_peripheral/Self_Wake_UP_2.0_SEGGER_Embedded_Studio/pca10028/s110/arm5_no_packs/Output/experimental_ble_app_blinky_s110_pca10028 nrf51422_xxac_s110/Obj/hardware_initialization.asm' for writing: No such file or directory

I don't understand, i can build the project without issue in Keil uVision. I follow the Blog tutorial from Hang Bui.

Any help would be appreciated. Thanks.

edit retag flag offensive close delete report spam


Hi RK,

Thanks for your answer, but i have others files builded without issue. I changed the path but i have the same error...

Yacire ( 2017-08-12 13:18:10 +0100 )editconvert to answer

@Yacire93: The blog post states that you need to use SDK v12.0.1 or newer, you are using SDK v10.0.0.

Bjørn Spockeli ( 2017-08-14 11:18:12 +0100 )editconvert to answer

Yes, i use the SDK 10.0.0 but i have tested with another example from the SDK 10.0.0 and it worked. I have tested with the app_ble_beacon from the SDK 10.0.0. So i don't understand why with my file hardware_initialization.c it doesn't work ...

Yacire ( 2017-08-14 12:11:41 +0100 )editconvert to answer

Could it be that you have not added the hardware_initialization.c file to the SES project or that the path is incorrect? Alos check if running SES as administrator fixes the issue.

Bjørn Spockeli ( 2017-08-14 12:57:03 +0100 )editconvert to answer

Ok it was the name of my file, strangely i change the name of the file to hdw_init.c and now it works without issue.Maybe it was because the file name was too long ...

Yacire ( 2017-08-14 17:39:57 +0100 )editconvert to answer

that's what I told you in my original answer. The entire path with the original filename was 260 characters long which is bigger than 256 which is where windows goes wrong. Had you just shortened some elements of the path as per the original suggestion so that all filenames with paths were shorter, it should have worked just fine.

RK ( 2017-08-14 22:06:39 +0100 )editconvert to answer

Yes, you were right RK, thanks for the additional information about the number of character of the path name allowed by Windows.

Yacire ( 2017-08-15 17:08:32 +0100 )editconvert to answer

2 answers

Sort by » oldest newest most voted
rols gravatar image

answered 2017-08-12 02:42:34 +0100

Yacire93 gravatar image

updated 2017-08-14 17:40:43 +0100

I'd suggest a shorter path, there have been many reports of windows having issues with long paths before.

edit flag offensive delete publish link more

answered 2017-09-02 12:03:07 +0100

I would suggest to try "Long Path Tool" program.

edit flag offensive delete publish link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer. Do not ask a new question or reply to an answer here.

[hide preview]

Question Tools

1 follower


Asked: 2017-08-11 17:07:05 +0100

Seen: 235 times

Last updated: sep. 02