0

Can bootloader in SDK V11 boot into SDK V12/13/14 application

Roland gravatar image

asked 2017-08-17 06:29:13 +0200

updated 2017-08-17 06:29:47 +0200

From document seems bootloader in SDK v12/13/14 does not support HCI/UART transport yet. So have to use SDK V11 bootloader.

However the application is based on SDK V13/V14. So the question is can SDK V11 bootloader boot into SDK V12/13/14 application?

edit retag flag offensive close delete report spam

1 answer

Sort by » oldest newest most voted
0
hungbui gravatar image

answered 2017-08-17 12:33:00 +0200

http://infocenter.nordicsemi.com/topi...

edit flag offensive delete publish link more

Comments

Thanks Hung.

I saw that link, however when i click the 'BootLoader module' link on that page, its bit confusing that following text still present: http://infocenter.nordicsemi.com/inde...

"However, the current implementation of the bootloader modules does not provide the full functionality yet. The current implementation focuses on a bootloader that allows Device Firmware Updates over BLE and that can be extended with security and compatibility checks. If you need a DFU bootloader that supports serial (HCI/UART) transport, use the DFU bootloader example from a previous version of the SDK (v11.0.0 or earlier) instead of the bootloader modules. "

Seem inconsistent. Which one is correct?

Another question as a new starter, the DFU example in V11 includes both BLE & UART, while in V13/14 the BLE and UART mode are in 2 seperate examples. Is there any special consideration behind this? the 2 main.c file ...(more)

Roland ( 2017-08-17 15:11:03 +0200 )editconvert to answer

Hi Roland,

The text should be updated. In previous version of the SDK (v12, v13) the serial bootloader was in experimental state. On SDK v14, it's moved out to production, and I would assume it should be full functional.

The bootloader from SDK v12 is a newly built bootloader, which has no backward compatible with the one in SDK V11. We call the bootloader from SDK v12: "Secure DFU". And the one on SDK v11 and earlier "Legacy DFU".

The bootloader from SDK v12 is built with good modularization, the two can be combined into one project, but there isn't much point doing so, as most of our customer only use 1 of the 2 transportation.

Hung Bui ( 2017-08-17 17:48:11 +0200 )editconvert to answer

Thank you Hung, that will be perfect.

Roland ( 2017-08-18 06:12:45 +0200 )editconvert to answer

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer. Do not ask a new question or reply to an answer here.

[hide preview]

User menu

    or sign up

Recent questions

Question Tools

1 follower

Stats

Asked: 2017-08-17 06:29:13 +0200

Seen: 42 times

Last updated: Aug 17