0

gdb: No symbol table is loaded. Use the "file" command. [closed]

mikeee gravatar image

asked 2014-09-14 02:45:41 +0200

When I try to set a breakpoint in eclipse by clicking on a line, gdb tells me in the eclipse "Console" window below the code: "No symbol table is loaded. Use the "file" command." The execution never stops as the breakpoint doesn't seam to get set. The J-Link GDB Interface doesn't tell me that it just set a breakpoint what I should do when it sets one.

Did anyone of you experience this? What is the solution to this so I can use the debugging feature?

My setup:

  • OSX Mavericks
  • Eclipse Kepler
  • pure-gcc setup
  • Command line J-Link GDB Server Interface
edit retag flag offensive reopen delete report spam

Closed as "no response from original poster" by Petter Myhre at 2014-10-09 13:34:17 +0200

1 answer

Sort by » oldest newest most voted
0
hkn gravatar image

answered 2014-09-19 14:07:39 +0200

You'll have to load the .out (or .elf) file using the file command in gdb:

file <myfile.out>

Check out this thread: https://devzone.nordicsemi.com/questi...

Cheers, Håkon

edit flag offensive delete publish link more

Comments

Sorry, only worked on this again now. The solution is to use the -g option to include debug symbols when compiling. When using pure-gcc add it to either the project makefile (ex. CFLAGS = -Os -g) or to the template. You don't need to use the file command as Håkan proposed, eclipse does that for you if you have set it up according to nAN-29 (load symbols check box in the startup tab of the debug settings).

Mike ( 2015-03-29 00:38:30 +0200 )editconvert to answer

Question Tools

Stats

Asked: 2014-09-14 02:45:41 +0200

Seen: 12,649 times

Last updated: Sep 19 '14