0

Building micro-ecc with SES, SDK14.1

jhendr gravatar image

asked 2017-11-14 19:23:30 +0100

Hi, I'm trying to build the secure_dfu_ble_s132_pca10040_debug project and apparently need to add the mico-ecc library. The SDK instructions for building the library call out " 4.9-2015-q3-update of the GCC compiler toolchain for ARM". I'm using Segger Embedded Studio, which is using "GNU ARM Embedded Toolchain version 6-2017-q2-update".

Should I use the 4.9 version as called out in the instructions, or should I use the SES version, which is what I'm trying to build the example with?

I'm working on a custom board based on the nRF52832. I'm developing on Win 8.1 using SES and a J-Link Plus. SDK version 14.1. Thanks in advance.

edit retag flag offensive close delete report spam

1 answer

Sort by ยป oldest newest most voted
2

answered 2017-11-15 14:51:49 +0100

I had the same setup as you and ended up downloading the 4.9-2015-q3-update of the GCC compiler toolchain for ARM. I never tried it with the Embedded Studio one.

edit flag offensive delete publish link more

Comments

Yes, it was very easy to build the example project after installing the 4.9 toolchain and building the ECC library, just as the direction in the link stated. Thanks for the input.

Jason Hendrix ( 2017-11-15 15:32:11 +0100 )editconvert to answer

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer. Do not ask a new question or reply to an answer here.

[hide preview]

User menu

    or sign up

Recent questions

Question Tools

1 follower

Stats

Asked: 2017-11-14 19:23:30 +0100

Seen: 49 times

Last updated: nov. 15