0

nRF51 DK - need to press RESET button to relaunch BLE advert. (and fails) [closed]

JohnM gravatar image

asked 2018-01-09 20:56:14 +0100

updated 2018-01-09 23:08:06 +0100

Hello,

Today I've a strange behavior of nRF51 DK (everything was working ok until today, the last things I did was to reset the J-link FW after a total erase of the board).

Now, when I upload the Softdevice (S130) and after my Application then I have to press button RESET on nRF51 DK to see my application in the nRF Connect Android ... and once I see it, the connection to my Application in nRF Connect is painful (it fails 75% of times and takes long time when it succeeds).

Do you have any ideas?

Thanks.

JohnM

edit retag flag offensive reopen delete report spam

Closed as "the question is answered, right answer was accepted" by JohnM at 2018-01-12 19:51:13 +0100

Comments

Are you using an SDK example or your own custom application? I'm guessing you didn't have to press the RESET button before to see your application in nrf Connect Android when everything was working, right? Would you mind uploading your code so I can test it here and see if I get the same error?

Bjørn Kvaale ( 2018-01-12 12:58:31 +0100 )editconvert to answer

1 answer

Sort by » oldest newest most voted
0
JohnM gravatar image

answered 2018-01-12 19:50:30 +0100

updated 2018-01-12 19:53:14 +0100

Trying to give you my example, I've found the issue: I had my PC Windows 10 Bluetooth running at the same time as my mobile phone Android!

That's why it was painful, erratic and pressing RESET on nRF51 DK board would somewhat solve it (I'm guessing). The Windows Bluetooth was trying to connect any time (via J-Link) conflicting with my mobile phone Android.

So the rule is to turn off the Bluetooth device on the platform we are developing on .

image description

edit flag offensive delete publish link more

User menu

    or sign up

Recent questions

Question Tools

1 follower

Stats

Asked: 2018-01-09 20:56:14 +0100

Seen: 144 times

Last updated: jan. 12