0

GATT_CONN_TERMINATE_LOCAL_HOST [closed]

zwf gravatar image

asked 2018-01-11 11:10:22 +0100

updated 2018-01-13 02:55:32 +0100

Log-2018-01-12-11-49.txtWhen I use the nrf connect app to connect my device, it often does not connect to my device.And i see the error on the log is: ERROR 22 GATT_CONN_TERMINATE_LOCAL_HOST. What is problem? Do you know? thanks!

app :nRF Connect

lenvo k320t android 7.0

nrf52832 SDK 12.2.0

edit retag flag offensive reopen delete report spam

Closed as "duplicate question" by zwf at 2018-01-17 09:55:41 +0100

Comments

Hi,

  1. I assume it is on the app (central) side you get the error?
  2. Have you tried other apps and phones?
  3. Would you be able to provide a sniffer trace? If you have a dev kit to spare you can use our tool.
  4. What softdevice version are you using?
Martin Børs-Lind ( 2018-01-12 13:05:43 +0100 )editconvert to answer

hi,

  1. yes,i get the erron on the app.
  2. With the exception of this phone, my other phones do not have this problem,but this phone(k320t) can be connected to other ble devices, such as da14580.
  3. Unfortunately, I do not have a sniffer
  4. sdk12.2

I uploaded an app's log。

thanks!

zwf ( 2018-01-13 02:54:42 +0100 )editconvert to answer
  1. Do you get any sort of logging info out of your peripheral?
  2. I cases like this, where BLE works on pretty much all phones but one, a sniffer trace is crucial to see what goes on between the two devices. As mentioned you don't need a high end sniffer. You can use a development kit from Nordic if you have one extra.
  3. If you cannot provide a sniffer trace I think we will need to see your code and test it here. Even that might be difficult since we don't have a K320T. I cannot find any other reports of issues related to the K320T either. You can upload your code here or in our official support portal, mypage, if you prefer confidentiality.
  4. What Softdevice are you using S132 v3.0.0?
Martin Børs-Lind ( 2018-01-15 17:24:49 +0100 )editconvert to answer

1 answer

Sort by » oldest newest most voted
0
zwf gravatar image

answered 2018-01-17 09:55:14 +0100

Now I know the reason for this problem, the phone does not meet the ble spec. thanks!

edit flag offensive delete publish link more

Question Tools

1 follower

Stats

Asked: 2018-01-11 11:10:22 +0100

Seen: 42 times

Last updated: jan. 17