Problem running/debugging nRF51822 GCC example project

Hello. I'm trying to start developing with the nRF51822 Eval kit with Eclipse and ARM GCC but I ran into some problems when trying to run the ble_app_hrs_example. I've been trying to solve it for the past two days but I'm pretty much out of ideas now so any help would be appreciated.

I installed and set-up everything the way it's described in the application note and flashed SoftDevice onto the eval board. The example program compiles without errors but when I try debugging I get strange behavior - I can step into and over lines of code, but the program doesn't stop at any breakpoints I set. In fact I get the following line (in red color) in the console every time I try to set a breakpoint:

Try to add breakpoint - No source file named C.

Another problem is that after I run he debugging session for the first time, the IDE starts reporting two errors in the file main.c on lines 308 and 673 -

Symbol 'app_timer_evt_schedule' could not be resolved

and

Symbol 'ble_stack_evt_schedule' could not be resolved

respectively. Both of these are defined as inline functions in headers which are included in the project so I don't understand what is the problem. Plese let me know if you need any more info, any help would be appreciated, thanks.

Related