`Could not power-up debug power domain.` with nrfjproj on nRF52

Hi,

I'm trying to use the nRF52832DK to flash a Rigado BMD-300 module (nRF52) - I've connected SWDIO, SWCLK, GND and voltage sense to P20.

It seems that because the protection bit comes set, you have to use --recover, and I did that but I get the following:

./nrfjprog --recover
Recovering device. This operation might take 30s.
ERROR: Cannot connect to any nRF device. Please make sure a device is
ERROR: connected to the debugger and supplied.

When enabling logging, it shows:

--------------------------------------------------------------------------------
./nrfjprog --recover --log
nrfjprog verion 8.4.0
--------------------------------------------------------------------------------
FUNCTION: open_dll.
FUNCTION: open_dll.
FUNCTION: enum_emu_snr.
FUNCTION: enum_emu_snr.
FUNCTION: enum_emu_snr.
FUNCTION: enum_emu_snr.
FUNCTION: connect_to_emu_with_snr.
FUNCTION: connect_to_emu_with_snr.
FUNCTION: connect_to_emu_without_snr.
FUNCTION: enum_emu_snr.
Device "NRF51822_XXAA" selected.
FUNCTION: recover.
FUNCTION: recover.
Found SWD-DP with ID 0x2BA01477
Could not power-up debug power domain.
Communication timed out: Requested 20 bytes, received 0 bytes !
Could not read hardware status!
FUNCTION: close_dll.
FUNCTION: close_dll.

It's done something, because the Rigado bootloader no longer shows in BLE, but it seems to have basically bricked the module now. I can't write any new firmware to it (either via nrfjprog or mass storage) - whatever I do I get the same Could not power-up debug power domain. message.

I've tried powering from a battery and the devkit's own power supply. Neither seems to make any difference.

Any ideas what could be wrong? This is causing serious problems - I've got prototypes here waiting to be programmed.

Parents Reply Children
No Data
Related