nRFUart Example - "Exception in StartMasterEmulator: -100"

I have tried using the pre-built nRFUart Example in the Master Emulator API (2.1.11.1) and get the above error

image description

I also tried rebuilding - no change.

I do have a PCA10000 dongle with the Master Emulator loaded, and Master Control Panel works fine with it:

image description

So what's missing?

Running on Win7-Pro.


Edit:

Updating the Question, as the comments can't show images or fixed-format text.

After the update, the nRFUart example looks like this:

image description

But pressing the 'Connect' button does nothing at all.

The Log File is attached:

log.txt

  • Could it be some version mismatch with the Master Emulator dlls and nrfjprog dll? What if you try to download the newest version of the MCP with ME from here: www.nordicsemi.com/.../46143
    I got it working here.

  • Well it's somewhat better - at least it no longer crshes with that exception.

    But the 'Connect' button does nothing - I press it, and nothing happens.

    I would post a screenshot, but that doesn't seem possible in a comment!

  • This is the log file:

    2;15:43:00.9468 [MainThread] Initialize MasterEmulator, Version=2.1.13.14, Culture=neutral, PublicKeyToken=null 3;15:43:01.0888 [MainThread] 480102122 - COM33 Open 4;15:43:01.1348 [MainThread] Open 5;15:43:01.1418 [MainThread] 480102122 - COM33 6;15:43:01.1878 [MainThread] - - Start of script: (2016-05-24 14:43:01) - - 7;15:43:01.1898 [MainThread] <reportfile:"C:\ProgramData\Nordic Semiconductor\MasterEmulator\log.txt"/> 8;15:43:01.2208 [MainThread] Device: COM33 9;15:43:01.2238 [MainThread] HciJLinkDriver opened (COM33, 1000000-8-None-1-RequestToSend) 10;15:43:01.2328 [MainThread] 480102122 - COM33 11;15:43:02.4519 [MainThread] HCI command: BTLE_CMD_READ_BD_ADDR 12;15:43:02.4539 [MainThread] Serial port write: 01-09-10-00 13;15:43:03.9210 [MainThread] Exception: No response from master emulator Could not read device address. 14;15:43:03.9230 [MainThread] Could not read device address. 15;15:43:03.9310 [MainThread] HCI command: NRF_CMD_GET_VERSION_INFO 16;15:43:03.9310 [MainThread] Serial port write: 01-06-FC-00 17;15:43:05.3320 [MainThread] Exception: Could not read controller version info. 18;15:43:05.3330 [MainThread] Could not read controller version info. 19;15:43:05.3400 [MainThread] HCI command: BTLE_CMD_LE_READ_BUFFER_SIZE 20;15:43:05.3400 [MainThread] Serial port write: 01-02-20-00 21;15:43:06.7411 [MainThread] Exception: Could not read buffer size. 22;15:43:06.7411 [MainThread] Could not read buffer size. Reset 23;15:43:06.7541 [MainThread] Reset 24;15:43:06.7621 [MainThread] 480102122 - COM33 Setup: add service 0x6E400001-B5A3-F393-E0A9-E50E24DCCA9E store REMOTE_STORE 25;15:43:07.9352 [MainThread] Setup: add service 0x6E400001-B5A3-F393-E0A9-E50E24DCCA9E store REMOTE_STORE Setup: add char def 0x6E400002-B5A3-F393-E0A9-E50E24DCCA9E 26;15:43:07.9682 [MainThread] Setup: add char def 0x6E400002-B5A3-F393-E0A9-E50E24DCCA9E Setup: assigned pipenumber 1 type TRANSMIT 27;15:43:08.0382 [MainThread] Setup: assigned pipenumber 1 type TRANSMIT Setup: add char def 0x6E400003-B5A3-F393-E0A9-E50E24DCCA9E 28;15:43:08.0402 [MainThread] Setup: add char def 0x6E400003-B5A3-F393-E0A9-E50E24DCCA9E Setup: assigned pipenumber 2 type RECEIVE 29;15:43:08.0442 [MainThread] Setup: assigned pipenumber 2 type RECEIVE Run 30;15:43:08.0542 [MainThread] Run 31;15:43:08.2272 [MainThread] Local server setup: 32;15:43:08.2302 [MainThread] 33;15:43:08.2322 [MainThread] Pipe setup: 34;15:43:08.2452 [] SERVER: Server has started 35;15:43:08.2522 [MainThread] Pipe 1: descriptor_info:None pipe_store:REMOTE_STORE handle:None service_id:1 parent_service_uuid:0x6E400001B5A3F393E0A9E50E24DCCA9E cccd_handle:None pipe_uuid:0x6E400002B5A3F393E0A9E50E24DCCA9E pipe_type:TRANSMIT parent_service_handle:None char_properties:None char_id:1 parent_char_uuid:None namespace_description:None Pipe 2: descriptor_info:None pipe_store:REMOTE_STORE handle:None service_id:1 parent_service_uuid:0x6E400001B5A3F393E0A9E50E24DCCA9E cccd_handle:None pipe_uuid:0x6E400003B5A3F393E0A9E50E24DCCA9E pipe_type:RECEIVE parent_service_handle:None char_properties:None char_id:2 parent_char_uuid:None namespace_description:None

  • Hmm... so posting logfile text is not workable, either.

    :-(

  • ... so I updated the question instead.

    The MCP (now version 3.10.0.14) does still work

Related