NFC not working on custom board

Hello Everyone, 

I am using nRF52832 and want to include BLE-NFC pair feature in the application that i am trying to develop. I am using SDK v14.2, Segger embedded studio as compiler and Softdevice version v5.0 on a windows platform.

Setup: Initially, i tried example ble_app_hrs_nfc_pairing and included ble nus service to it on nrf52 DK (PCA10040, v1.2.1). It worked perfectly well. So now, having tested the functionality i tried porting the same on to my custom board to evaluate the ble-nfc pairing feature.

Problem: There is no error during compilation. But when i try to bring a smartphone near to the board to test the pairing, NFC is not at all working. While debugging, i see that the NFC_IRQHandler is not called, so seems like NFC field is not detected so as to start sensing and pairing. 

I checked the peak to peak differential threshold voltage to see if the voltage level is too low for NFC to sense the field, but that is also fine (around 2.4 V, once i bring in the smartphone near to the NFC antenna).

Could anyone of you please let me know what could be the reasons that NFC is not able to work? Or any configurations/ macros i might have missed to support the feature? 

Any help is appreciated. 

Thank you!  

Parents Reply Children