How to downgrade nRF Connect plugins?

I have issues running the upgrade of nRF Conenct (too old linux version to run nRF Connect 3).

I tried to downgrade, downloaded v2.6.2 appimage from https://github.com/NordicSemiconductor/pc-nrfconnect-core/releases and wanted to run PPK nd BLE again.

Unfortunately I already upgraded the plugins.

Is there a way to get the packages of older plugins to install as described in https://github.com/NordicSemiconductor/pc-nrfconnect-core#manual-installation-of-apps

I tried cloning the repository of PPk and installing it manually but didn't have the correct versions of node.js, npm, ...