Dongle stopped working - no application and no DFU mode.

Hi there,
My nRF52840 Dongle suddenly stopped working. The application that used to work among a few last weeks stopped during one of exploatation. Pressing Reset Button don't start the DFU mode. I see that 5V comes to USB, and VDD nRF is 1,6V, so I don't suspect power failure, rather the Flash issue. How to solve it? Is there any simple recovery procedure like with DK?

  • Hi

    Can you confirm that you try pressing the button mounted sideways by the big white one in order to put it into DFU mode? If that doesn't work, check out tour Dongle Programming tutorial, and the sections on Recover after an UICR erase, and Revert to production bootloader to see how you can get it back up and running in most cases.

    Can you also explain what you mean with the device stopped working during exploatation, as that's not clear to me.

    stopped during one of exploatation.

    Best regards,

    Simon

  • 0
    10 pts.
    in reply to Simonr

    I'm sure I use Reset button, not the User button. I've been using the dongle for some time so I know the difference you mean.
    Okey, I'm gonna try to revert to production bootlader. I see it's gonna need some soldering to use SWD. I hope it's not a broken chipset.

  • 0
    10 pts.
    in reply to Simonr

    I mean, program just stopped to work - suddenly the user LEDs turned off and VCOM runned with USB CDC dissapeared from Windows.

  • Hi

    Let me know how the reversion to the prod. bootloader went. 

    The other reply: Did it "just stop working" while just running application code, while doing the DFU, or while programming the Dongle?

    Best regards,

    Simon

Related