nRF 52840DK debug out on board version 3.0.0 not working

Hi there, 

We have recently purchase some more nrf52840DK to develop and program custom boards based on the same SoC. The new DK (from Digikey) have the following sticker

When we use them to program other nRF52840 SoC, it looks like the external board is not recognized.

With some other earlier version of the nrf52840DK (2.0.2, 2021.43) everything was working fine. Could you please help us understanding what possible issues might be at stake ?

More info: I have also tried to pull down the GND Detect as mentioned here:  Using Debug Out (p19) to program 3rd Party nrf52840/nrf52810 boards with issues , but when looking at the DK 3.0.0, on Debug Out P20 connector, it looks like the GND Detect pin is no longer present (at leas the label is not). 

Many thanks for your help.

Best regards, 


Parents Reply
  • Sorry, didn't notice the guys didn't use the same naming on all the nets. The VTG pin on the nRF52 DK is still the same as the SWD SEL functionality wise, all the DKs use the same code for the debugger so functionality will be the same for the same OBD.

    We did a change in OBD (On Board Debugger aka JLINK) device between the 2.x version and the 3.x version and that changed the functionality on some of the pins. If you follow the user manuals to the letter it should still work but if you don't mount all the lines as instructed (like you did) then you can get problems with the programming of external targets.