0

nRF51 doesn't show up anymore aftering bootloader mode

hasanble gravatar image

asked 2017-04-21 11:05:01 +0100

Hello,

After (accidentally) entering bootloader mode on my nRF51 DK (PCA10028), the device doesnt show up either in the device manager or using nRFgo Studio (both not normally, as being in the bootloader mode where LD5 is blinking.)

In case I turn the DK on and off normally (without pressing the reset button), the LD5 doesnt blink or turn on otherwise. If I turn the DK on while holding reset, BOOTLOADER shows up as a USB device, and the LD5 blinks.

Can anyone help me out, thanks in advance.

edit retag flag offensive close delete report spam

1 answer

Sort by ยป oldest newest most voted
2

answered 2017-04-21 11:43:00 +0100

Have you tried reprogramming your debugger?

Enter bootloader mode and drag and drop a debugger firmware image onto the drive. The image can be found at nRF5x-OB-JLink-IF. After programming is done, the green debug led should start flashing rapidly. After power cycling your board it should be back to normal.

edit flag offensive delete publish link more

Comments

Thank you, worked like a charm.

I am still wondering though, why it was first working without having any firmware image on it. Or was it not showing in the BOOTLOADER drive? I.e.: What exactly did we just do?

hasanble ( 2017-04-21 11:48:24 +0100 )editconvert to answer
1

The DKs come preprogrammed with the firmware image. I'm guessing you somehow did something to erase or overwrite this when you entered bootloader mode by accident. This can happen if you tried to program the nrf52 with the BOOTLOADER drive for instance.

Simen August Tinderholt ( 2017-04-21 11:55:49 +0100 )editconvert to answer

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer. Do not ask a new question or reply to an answer here.

[hide preview]

Question Tools

1 follower

Stats

Asked: 2017-04-21 11:05:01 +0100

Seen: 66 times

Last updated: april 21