Disable ACK at Receiver in Enhanced Shockburst

ajacobs@perceptimed.com gravatar image

asked 2017-08-17 06:12:06 +0200

Hi Nordic,

I am using ESB_DPL SDK ver 13 for communication between one nRF51822 transmitter and multiple nRF51822 receivers with data whitening. I do not want the receiver to ACK any packets and have disabled auto_ack on the transmitter by setting .noack= true and .selective_auto_ack = true.

Testing is showing that the receivers are sending ACKs in response to what appear to be packets from other nRF51822 transmitters in the area that are sending messages with auto_ack enabled, or perhaps without data whitening enabled. In ESB_DPL control of whether the receiver sends an ACK is based on the TX payload.

Is there a setting on the receiver that will disable the receiver from ever sending an ACK regardless of whether the TX payload is requesting an ACK?

edit retag flag offensive close delete report spam

Comments

Hi Alan

When you say "other nRF51822 transmitters", do you mean devices outside your control?

What are your address and CRC configurations?
Unless you have both an address and a CRC match you should not send an ACK, so it seems odd that you would respond to random packets in the area.

Best regards

Torbjørn Øvrebekk ( 2017-08-18 09:02:49 +0200 )editconvert to answer