wireshark not capturing ble packets

Suvarna gravatar image

asked 2017-09-14 10:08:17 +0100

Hi I am using wireshark 1.10.6, when press 'w' wireshark started but it is not capturing packets. even I select my device then also facing same problem. I waited for some time and then wireshark popup this error. The capture session on "\.\pipe\wireshark_nordic_ble" timed out during pipe open: The semaphore timeout period has expired.(error 121) When I used wireshark without sniffer it is capturing Ethernet packets successfully. Is there any wrong or extra settings I need to do?

details of system I am using windows 10pro x64 sniffer hardware nRF51 dongle 10031 peripheral device nRF51 Dk 10028.

edit retag flag offensive close delete report spam

Comments

Are you running sniffer.exe as admin?

Did you see this under Troubleshooting in the User Guide?

Wireshark is not able to display the sniffed packets.

The Sniffer will generate a Wireshark capture file (%APPDATA%\Nordic Semiconductor\capture.pcap) which can be viewed afterwards even if real time viewing is not used. Press s to view the folder with the file.

Petter Myhre ( 2017-09-14 12:35:21 +0100 )editconvert to answer

Hi Petter, Thank you, it working the way mention in the manual. but why packets are not showing when wireshark started through sniffer?

suvarna_kadam ( 2017-09-14 14:35:06 +0100 )editconvert to answer

Unfortunately, I'm not sure why.

Petter Myhre ( 2017-09-14 15:02:42 +0100 )editconvert to answer

Hello Petter, I am facing the same issue as Suvarna. I need to able to view the packets transmitted in real time to analyze a sample app that we are developing. The Sniffer worked fine for approximately 3 weeks when we were testing out the iOS version of our app. When we switched over to Android, I noticed that the packet capture used to stall and after a period of time, the Sniffer became completely unreliable. Now, I am not able to view the advertising devices even when they are paired with an iOS app. On some rare occasions, advertising devices are displayed on the Sniffer console window. When I start sniffing particular devices, I am able to view the packets only as background logs and that too the logs are not for the entire duration of the sniffing interval. I have tried re-flashing the firmware into the device, without ...(more)

krishnanmc3 ( 2017-10-03 11:55:00 +0100 )editconvert to answer

@krishnanmc3 Could you please create a new question add a link to this if it is relevant? Also, also please include if you can see the trace afterwards. Also include which J-Link version and Wireshark version you are using.

Petter Myhre ( 2017-10-04 08:38:45 +0100 )editconvert to answer