add libuarte to central&peripheral

Hello,
Im working on project that communicate with gps/gprs and it works with the example/peripheral/libuarte. 
but when I want to integrat it (add) it to central peripheral id doesnt :
I added the same "drivers" that are used on libuarte example and "library" and "sdkconfig" and also "User Include Directories"

here is my logs of errors:

  • Hi

    It seems like you haven't added the nrf_error.h header file to your example, which is found either in the SoftDevice header files or \SDK_FOLDER\components\drivers_nrf\nrf_soc_nosd\nrf_error.h if you're not using a SoftDevice in your application. Have you started out with a project from scratch here? We generally recommend starting out from an already existing example, as there are quite a lot of files that need to be added when making a project from the ground up. Seems like the libuarte example would be a great starting point for you.

    Best regards,

    Simon

  • I worked based on "libuarte" example, I added all drivers and all librarire and ble services and softdevoce used on the example of "ble_app_hrs_rscs_relay"  and even get the same sdkconfig of the relay example that actovate the softdevice , but nothings change, still have the issues (nrfsucces undelcared).

  • here is the file that, Is based on libuarte sdk16, I adeed to it BLE (centralperipheral)
    If you want to take a look on it 

    BLE_LIBUARTE.zip

  • How does the path to your project look on your computer? I think it's not able to find the user included directories due to the path or path length being incorrect on your side. On my side I get an error saying that the following definition is missing in your sdk_config.h file.

    // <q> NRF_LIBUARTE_ASYNC_WITH_APP_TIMER  - nrf_libuarte_async - libUARTE_async library
     
    
    #ifndef NRF_LIBUARTE_ASYNC_WITH_APP_TIMER
    #define NRF_LIBUARTE_ASYNC_WITH_APP_TIMER 1
    #endif

    Best regards,

    Simon

  • the path to my project is : /Volumes/HDD/Projects/nRF5SDK160098a08e2/examples/ble_central_and_peripheral/BLE_LIBUARTE/pca10040/blank/ses/libuarte_pca10040

    and for the sdkconfig , the definition is present . I think there is a probleme with some thing related to softdevice , beauce there I added the BLE things .
    thanks you,


    6445.BLE_LIBUARTE.zip

Related