PHY coded and Coexistence

damien5606 gravatar image

asked 2017-12-07 11:49:57 +0100

Hello,

I'm testing PHY coding (for long range), I'm pretty surprise from what I get when I scan the RSSI of bluetooth channels (with Nordic app).

This is my set up:

image description

M1 is the central, S1 is the peripheral sending 1ko/s. (with uart exemple) I use softdevice 140 V5 alpha.2

M3 is the RSSI scanner connected to "Nordic app RSSI Viewer" Here are the results I get for phy= 1mbps (Short Range) and for phy=125kbps (coded-Long Range):

  1. Short Range image description
  2. Long Range image description

Can you explain me why the long Range mode trash all Bluetooth channels ? this is one link (S1-M1) so my data received is what I expected (1ko/s) but when I use 10 links, the data rate drops dramatically.

Regards,

-Damien

edit retag flag offensive close delete report spam

Comments

Hi,

It seems like we still have some issues with the coded PHY. Here are two relevant cases:

https://devzone.nordicsemi.com/questi...

https://devzone.nordicsemi.com/questi...

We don't know what it is yet, but we are looking into it. Just a few simple questions to get us started:

  1. Do the RSSI spikes in the frequency band always occur on those channels? Or can you see them move from test to test?
  2. Can you try to switch the kits and see if the band looks the same or if the tops might shift?
  3. What is ko/s? I'm unfamiliar with that unit.
  4. When you use several links, do you see the same as user @damien5606: https://devzone.nordicsemi.com/questi...
  5. Can you try the latest v6 alpha?
Martin Børs-Lind ( 2017-12-07 14:03:57 +0100 )editconvert to answer

(1/2) Thank you for your answer Martin,

  1. From what I see, the RSSI spikes seems to have a 10MHz spacing. And It looks like there're at least 4-5 spikes at the same time and all of them are shifting over the time. I see spikes on 2440MHz + 2450MHz + 2460MHz + 2470MHz (at the same moment) shifting to 2439MHz + 2449MHz + 2459MHz + 2469MHz then to 2438MHZ + 2448MHz + 2458MHz + 2468MHz ... So the total RSSI activity looks like to be 40-50MHz wide and shifting (to the left), and it looks like to be periodic of 2 seconds.
  2. The previous results were on nrf52840pdk V0.91 : https://ibb.co/jKXonw, on V0,92 it seems that this "wave" is larger: https://ibb.co/b7nzCw. and this is for V0.93 : https://ibb.co/nf8NXw (looks a bit better)
  3. Sorry it's koctet/s (french I guess) = kBytes/s
  4. yes, I'm damien5606, I created ...
(more)
damien5606 ( 2017-12-07 16:19:09 +0100 )editconvert to answer

(2/2)

  1. As I said in my previous post, I used the throughput_example_connecting_on_long_range on Alpha V6 of SD140 softdevice and I observe the same results. (drop of data rate when I'm adding links)

To my mind it comes from the hardware side (since the results look different when I change the nrf52840pdk version).

Regards, Thank you for your help,

-Damien

damien5606 ( 2017-12-07 16:23:33 +0100 )editconvert to answer

Are you using the same connection intervals (CI) in both of those tests? I have done some tests myself and when I use coded phy and 400ms CI the RSSI viewer looks like your top most picture. If I use coded phy and 7.5ms CI it looks more like the image at the bottom. This is probably because the channel selection algorithm is designed to change channel between each connection events. Since you have turned on "Channel Scan Repeat" in the RSSI viewer you will get sort of an average view over the last couple of connection events, which manifests itself as the "ripple" in the RSSI plot.

Martin Børs-Lind ( 2017-12-08 15:51:44 +0100 )editconvert to answer

(1/2) Yes, I'm using the same CI on those tests. MSEC_TO_UNITS(10, UNIT_1_25_MS) for uart_app. (For all the tests I've done with those pictures) When PHY is coded (bottom picture), the data is staying 8x longer in the air that's might be why I see a RSSI stronger signal (than the short range, top picture).

But I've an other project, base on the nrf52832 chip with a 5kBytes/s data rate (at PHY 1Mbps) with the same CI, So I guess It should corresponds to 625Bytes/s in coded phy if you compare on-air time and It's not that far from the 1000Bytes/s data rate from the bottom picture. And I don't see any RSSI activities like the one I see here on long range.

I understand that my RSSI viewer set-up do kind of an averaging and maybe there's only ...(more)

damien5606 ( 2017-12-08 17:27:32 +0100 )editconvert to answer

(2/2) Do you think my central boards (receiving notifications only) can be to close to each other (5cm during my tests) so a signal even on an other channel can disturb and prevent the reception ?

damien5606 ( 2017-12-08 17:31:06 +0100 )editconvert to answer