RSS
Sort by » date activity ▼ answers views votes

28,684 questions

18
views
no
votes
1
answer
Last activity 2018-01-18 12:44:55 +0100 by Jørgen Holmefjord flag of Norway

Thread border router - IPV6 DHCPv6 problem

Hi there,

I'm using ASUS RT-AC1900P router with IPv6 DHCPv6 on. RPi gest its own IP with prefix specified in router but interface wpan0 (wpantund) not. I have configured the Router properly, the static IPv6 with /62 prefix. My ... (more)

26
views
no
votes
no
answers
Last activity 2018-01-18 12:09:10 +0200 by chocol8

Whitelist disconnection problem

Hello,

My setup is: ble_uart_app example, custom board with nrf51822, sdk 6, s110, nrf connect for pc.

I am advertising with my peripheral device. Whitelist is being applied to connections. I am able to connect to the devices which static ... (more)

61
views
1
vote
1
answer
Last activity 2018-01-18 11:53:30 +0200 by RK flag of Singapore

Add service after connection

Hi all, Is it possible to hide a Service during advertising? And show it after the connection?

If yes, how?

My configuration:

  • nrf52832 microcontroller
  • Softdevice S132 V4.0.2
  • Nordic SDK 13.0

Thanks

28
views
no
votes
1
answer
Last activity 2018-01-18 10:45:52 +0200 by Andre

BLE not starting in custom Board of NRF52832

Hi,

We made a custom PCB using the NRF52832 and followed the reference design. While everything else is working in our system, the BLE part is not working. We are using SDK 12.3 with Softdevice of S132. It seems ... (more)

55
views
5
votes
1
answer
Last activity 2018-01-18 10:40:33 +0200 by Martin Børs-Lind flag of Norway

Custom GATT - central hangs when connecting: nRF52810 + S112 | armgcc @SDK14.2

Hello,

I am trying to get a BLE peripheral with a single service containing a single custom read-write characteristic.

Unfortunately, any time I initiate a connection to the device the device stops advertising and the connection hangs. The connection never ... (more)

25
views
no
votes
1
answer
Last activity 2018-01-18 10:30:19 +0200 by Andre

Reset Button not working as expected in the Custom PCB Board NRF52832.

Hi,

We made a custom PCB using the NRF52832. We have connected a button to P0.21 which is the reset pin. We have configured this button as input and set the preprocessor flag to CONFIG_GPIO_AS_PINRESET. When we press this ... (more)

44
views
no
votes
1
answer
Last activity 2018-01-18 10:25:28 +0200 by Andre

No connection when using the DC/DC converter

Hi I don't get a connection when I run boards from PCBWay, but it works fine with the same boards manufactured by Eurocircuit. When I comment out the statement below, boards from both manufacturer works fine.

err_code = sd_power_dcdc_mode_set(NRF_POWER_DCDC_ENABLE ...
(more)

82
views
1
vote
1
answer
Last activity 2018-01-18 09:46:25 +0200 by shibshab

Giving read permission of a characteristic to a specific connected peer in multiperipheral device

Hi,

I am using multiperipheral configuration. I want a characteristic to be read by only a specific peer among connected peers. How do i recognize and authorize this specific peer every time it connects.

I am using PCA10040 , S132, SDK ... (more)

106
views
no
votes
2
answers
Last activity 2018-01-18 07:58:00 +0200 by efiLabs

slow ble uart on sdk14.2.0 s132 52832 device

i have 2 setups, one on a pca10040 running sdk 14.2.0 s132 and the other one on a pca10028 clone running sdk12.3.0 s130 with a 51822_xxaa mpu

the ble_uart examples from both sdks got the following ... (more)

81
views
no
votes
1
answer
Last activity 2018-01-18 07:57:01 +0200 by efiLabs

low peripheral gatt data transmit throughput with s132-5.0

i took the original sdk 14.2.0 s132-5.0 ble-uart nus-service example for reference measurements to send data from a 52832 to an android device running nrf uart v2.0

to provide a measurable data stream i do not ... (more)

218
views
2
votes
1
answer
Last activity 2018-01-18 07:55:26 +0200 by suvarna_kadam

external crystal

Hello is a starter developer I used the nrf51822 chip on the pcb board and downloaded the example code but it did not work. When I checked the 16mhz external crystal on the pcb board, the clock was not being ... (more)

202
views
1
vote
1
answer
Last activity 2018-01-18 04:46:44 +0100 by wangyong flag of China

51822 + PA

Hi everyone. I want to add RFX2411N to extend BLE signal coverage. I also need to minimize power consumption. I used VDD_PA to control TXEN and 2 gpios control both TXEN and MODE. The PA is set to bypass mode ... (more)

54
views
no
votes
no
answers
Last activity 2018-01-18 02:20:16 +0100 by liuliying

Problem setting up calibration resistors

We are in the development stage of a product that uses the nRF52832 and have acquired a nRF6707 Rev 1.1.0 power profiler kit to make power consumption measurements.
I am using it plugged into a nRF5x DK.
I ...

(more)

19
views
1
vote
1
answer
Last activity 2018-01-18 02:16:58 +0200 by puff

softdevice fault handler, id=1, pc=0x104fa, s130 v2, 51822

Is that called from SD space or APP space? SES project file attached. nrf5-ble-tutorial-characteristic-CompletedCode.zip

176
views
no
votes
1
answer
Last activity 2018-01-18 01:28:05 +0200 by Ladasky

nRF52 USB-UART broke, half-duplex?

Hi there,

I have multiple PCA10040 boards, and about a year's worth of experience developing code for them. I have suddenly started to have problems with USB-UART connections. Not even Nordic's SDK example code (in ../examples/peripheral/uart ... (more)

25
views
no
votes
no
answers
Last activity 2018-01-17 23:18:30 +0100 by Andres Zubillaga

MPU9255 + nrf52 (PCA10040)

Hello,

I am currently using SEGGER studio with SDK11 and the MPU9255 repository from https://github.com/Martinsbl/nrf5-mpu... . I followed the installation instructions in the repository. Then I installed Segger Studio and used the tutorial to develop in older ... (more)

52
views
2
votes
1
answer
Last activity 2018-01-17 22:27:23 +0100 by mon2 flag of Canada

nRF52840-PDK bricked

I purchased the nRF52840-PDK the other day and when it came in today Booted it up and it worked fine. I went to load the example nrf52840_xxaa_side_header.hex from the github page onto the board with the drag and drop ... (more)

28
views
no
votes
1
answer
Last activity 2018-01-17 21:48:28 +0100 by jwillner1958

BLE advertisement period / phase

I would like to synchronize my warning lamps with the advertisment of a master device.

The master is the advertiser as peripheral device. once every second.

The slaves are scanner as central device. When they detect the advertisment they synchronize ... (more)

12
views
no
votes
no
answers
Last activity 2018-01-17 21:15:17 +0200 by oliverpoc

Flashing light when connect my nRF51 board with computer

It worked before when I connected my nRF51 board to my windows 7 computer. The green light is on. But today when I connect them the light is blinking rapidly and there is no connection. In nRFgo studio it shows ... (more)

68
views
1
vote
1
answer
Last activity 2018-01-17 20:52:33 +0200 by Pasquale

Reducing latency - BLE nano as MIDI controller

Hi All, I am building a wireless MIDI controller using the BLE nano v2.0 from RedBearLab. MIDI is a protocol to control software musical instrument, therefore latency needs to be <10ms and at the moment it ranges roughly between ... (more)

38
views
no
votes
no
answers
Last activity 2018-01-17 20:32:13 +0100 by KV

APP_ERROR_CHECK outside main while(1) loop

I want to check if some errors happened during the initialization before entering while(1) loop in the main. I am using nrf_CLI in my application (SDK 14.2.0 and S140 on nRF52840).

So my main function looks like ... (more)

42
views
no
votes
no
answers
Last activity 2018-01-17 20:09:19 +0200 by puff

err_code symbol not found error when debugging in segger?

When debugging a project from here https://devzone.nordicsemi.com/tutori... (the ready code from github) Segger Embedded Studio shows err_code sybol not found message in Watch winow, when I try to debug gap_params_init(), however, in other calls before it ... (more)

83
views
2
votes
1
answer
Last activity 2018-01-17 19:55:29 +0100 by puff

How is it possible that my app doesn't start unless I start a debug?

I am playing with example app from this tutorial https://devzone.nordicsemi.com/tutori... I can see the app only when I start debugging. If I just power up my custom board, it doesn't show the app in my ... (more)

24
views
no
votes
no
answers
Last activity 2018-01-17 18:10:25 +0200 by Florent

nRF52832 PWM loop forever between duty cycles defined in a sequence

Hi,

This is my first post here. I hope I will follow the structure of a good question.

I want to have a sequence of defined duty cycles (let's say 4 values). The aim is to loop forever between ... (more)

35
views
no
votes
no
answers
Last activity 2018-01-17 17:36:34 +0200 by Gerry

Send and receive a string via access layer

Hi Team

I studied the examples for Bluetooth 5 mesh but i didn't find an example to communicate through access leyer. Can you give us some example lines of code, how this can be done? I'm working with ... (more)

31
views
1
vote
no
answers
Last activity 2018-01-17 16:33:16 +0100 by floatcloud

Chip freezes in normal operation, but no problem when debugging

Hi all,

I recently encounter this strange issue that I couldn't understand. My code works perfectly fine during debugging on all 52832 chips, but freezes without response from time to time on some of the chips if run without ... (more)

23
views
no
votes
no
answers
Last activity 2018-01-17 16:27:24 +0200 by Matej

scan response on undirect advertising with whitelist

Hi guys,

I'm playing around with advertising with whitelist and filter policy setted to both... And everything works as expected...

All central devices are able to see advertise messages but not scan responses - because they are filtered out... Once ... (more)

28
views
1
vote
1
answer
Last activity 2018-01-17 15:03:25 +0100 by Gordon

sd_radio_notification_cfg_set no longer usable with SD in SDK 14

Hi,

I've been trying to update Espruino (https://github.com/espruino/Espruino) from using SDK 12 to SDK 14, which is proving to be a pretty horrific task.

The latest issue I've hit is that I was using ... (more)

36
views
1
vote
1
answer
Last activity 2018-01-17 14:50:39 +0200 by Jørgen Holmefjord flag of Norway

I want to set up a serial communication between arduino and nrf52840 ?

i have programmed a arduino to send data(int value) on tx ,rx pin .How shoul i set up the nrf52 (the pin no of rxd and txd on nrf are p0.6 and p0.8).Which example should i ... (more)

68
views
no
votes
1
answer
Last activity 2018-01-17 14:48:54 +0200 by trdop

problem of re-requesting frequent pairing for no apparent reason

Hello the Nordic Team,

First, I wish you all a Happy New Year 2018, with a lot of good health and success in your professional and personal projects. Secondly, I come here to make aware of a problem that is ... (more)

Statistics

  • Total users: 26301
  • Latest user: Thalia Despeissis
  • Resolved questions: 11537
  • Unanswered questions: 4027
  • Total questions: 28684

User menu

    or sign up

Recent questions