nRF 52840DK debug out on board version 3.0.0 not working

Hi there, 

We have recently purchase some more nrf52840DK to develop and program custom boards based on the same SoC. The new DK (from Digikey) have the following sticker

When we use them to program other nRF52840 SoC, it looks like the external board is not recognized.

With some other earlier version of the nrf52840DK (2.0.2, 2021.43) everything was working fine. Could you please help us understanding what possible issues might be at stake ?

More info: I have also tried to pull down the GND Detect as mentioned here:  Using Debug Out (p19) to program 3rd Party nrf52840/nrf52810 boards with issues , but when looking at the DK 3.0.0, on Debug Out P20 connector, it looks like the GND Detect pin is no longer present (at leas the label is not). 

Many thanks for your help.

Best regards, 


Parents Reply
  • Thank you so much for clarifying that! I was finally able to flash target board. Documentation not being up to date didn't make it easy.

    I would also really appreciate if you could point me to where I could find any information about debugging code on target board. I tried to do it via VS Code, but without success. I created build configuration optimized for debugging. I'm able to flash the board via VS Code. But when I try to debug (or attach debugger to target) I'm getting something like this: